Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I reinstall a server Windows Server 2008 R2, I installed SQL Server 2008 R2 no problem during installation. When I try to connect with "Microsoft SQL Management Studio" via sa account or Windows Administration account, I have this error (picture1), the second picture (picture2) show the services staarted.

I read some posts about this but no success :(

Picture1: alt text

Picture2: alt text

share|improve this question

6 Answers 6

Isn't that the default instance, for which you DO NOT GIVE A NAME IN THE CONNECTION STRING?

share|improve this answer
1  
To clarify, just put localhost in the Server name: field –  nick Oct 6 '11 at 5:07

Start->Programs->SQL Server->SQL Server Configuration Manager->SQL Server Browser->Properties->Start Mode = Automatic

share|improve this answer

Use an alternative representation of the name of the local host address instead of "localhost". Possible alternative representations include the following:

  • 127.0.0.1
  • (local)
  • "."
  • The actual local host name

For example in your server try to change Server name field like so :

(local)\MSSQLSERVER or .\MSSQLSERVER

For predefined instance type you need to use only : localhost or 127.0.0.1

have you enabled REmote Connection to SQL Server ?

you could also try with this step-by-step guide : http://www.linglom.com/2009/03/28/enable-remote-connection-on-sql-server-2008-express/

share|improve this answer
    
tried, same result –  Kris-I Sep 5 '10 at 7:39
    
Is the SQL Server configured with named instances or predefined instance ?How do you have installed it? Have you enabled TCP-IP connection ? –  aleroot Sep 5 '10 at 10:21

Have you run SQL Server Configuration Manager yet? That should be your first stop after the install (and patching).

Start Menu -> All Programs -> Microsoft SQL Server 2008 -> configuration tools -> SQL Server Configuration Manager.

By default, there's not much connectivity enabled -- this is where you'll fix that.

alt text

share|improve this answer

Have you added rules for the firewall?

There is a picture here > http://sqlsolace.blogspot.com/2009/08/windows-2008-firewall-rules-for-sql.html

share|improve this answer

In Instance Name when you're connecting from local computer on which SQL Server is installed you don't need to enter anything else expect localhost. Eg., Localhost\mssqlserver is not acceptable. Enter only localhost and try to connect. When you're connecting to SQL Server from remote computer at that time in server name you need to enter ComputerName\SQLServerName.

For Remote Connections Settings Please refer below link.

http://www.linglom.com/2009/03/28/enable-remote-connection-on-sql-server-2008-express/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.