Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Recently, my ubuntu box encountered a power failure. After rebooting, the HWAddress of eth0 is showing a very weird number: 00:00:00:00:00:30. I have tried sudo ifconfig eth0 down & sudo ifconfig eth0 up. Also, my ubuntu box is no longer acquire IP address from the DHCP server (A Buffalo Router) any more. What's wrong? How should I deal with such?

Edited: Sorry for any mislead this question may cause. I actually see the HWAddress of eth1 instead of eth0. I looked at /etc/udev/rules.d/70-persistent-net.rules and found that there are two entries, one for 00:00:80:00:00:30 which basically assign my LAN card to eth0 and another entry for 00:00:00:00:00:30 which assign my LAN card to eth1. I guess my LAN card is broken?

share|improve this question

4 Answers 4

If you set a static IP address, do you get packet flow? Perhaps the NIC has died?

share|improve this answer
    
When I look at /etc/udev/rules.d/70-persistent-net.rules, I saw there are two entries, one for 00:00:80:00:30 which basically assign my LAN to eth0, and another one for 00:00:00:00:00:30 which assign my LAN to eth1. Does that signal my LAN card has been damage after a power sock (power failure) or it's just a common problem with file corruption after power failure? –  Phuong Nguyen Sep 6 '10 at 13:15
    
This means that Ubuntu has seen a new NIC and a new MAC address on powerup, and has added the device at eth1. Probable that your NIC has been damaged. Assign a static IP and try for packet flow, or boot into a Live CD as user48838 suggested and see what MAC that OS sees. –  justinsteven Sep 8 '10 at 2:22

You can use ifconfig eth0 hw ether 12:34:56:78:90:AB to reset the MAC address (but put in the correct MAC address, or at least a reasonable one).

share|improve this answer
up vote 1 down vote accepted

I checked the files /etc/udev/rules.d/70-persistent-net.rules and saw the new eth1 device being defined. For some reason, the observed MAC of my NIC has changed, and such Ubuntu is trying to assign the NIC a new name (eth1). By overriding the MAC associated with eth0 by the MAC associated with eth1, then delete the entry for eth1, the problem has gone away after reboot. Thanks you guys for help.

share|improve this answer
  1. You should be able to head over to "Edit Connections..." by right-clicking on the networking status icon on the upper right-hand corner by the system time.

  2. Select your network adapter then the "Edit" button on the right.

  3. You should then be able to correct the MAC address for your network adapter.

share|improve this answer
    
Is there a way to do that with command-line? (I have a server edition with very minimal gnome desktop installed). By the way, how could I find the correct Mac Address? –  Phuong Nguyen Sep 6 '10 at 4:18
    
You can try nm-system-settings.conf under /etc/NetworkManager by updating the no-auto-default="MAC Address" (without the quotes). The NIC's MAC address is typically on a stick either directly on the NIC or on the unit's chassis/case. Worse case, you can look into booting a CD-based OS and looking up the MAC through the original approach or similar (depending on the OS). –  user48838 Sep 6 '10 at 4:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.