Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here's my scenario:

I've got a VisualSVN server on my main dev box @ home. I'm also using Visual Studio 2010, TortoiseSVN, VisualSVN client (for source control), and Versioned 'Artifacts' (for bug tracking).

(I had to modify the fake URL's below to use only one slash because as a new user, I can't post more than one real URL.)

I've got my Buffalo AirStation WHR-HP-G300N router properly configured so my business partner can connect to the SVN server. I have port forwarding enabled for the internet-side IP address (like http:/99.888.77.66:443) which gets forwarded to an internal IP (like 192.168.11.6). This part is working great.

The problem I'm having is with the integration piece between TortoiseSVN and my bug tracking system. I need to provide a bugtraq:url property, but I haven't been able to get relative paths to work. So I'm forced to use an absolute URL. On my end, I need to use the name of my server (for example: bugtraq:url = https:/my-server/svn/bla..), but this doesn't work for my partner. He needs to specify the IP address (for example: bugtraq:url = https:/999.888.77.66:443/svn/bla...)

Is there a way to configure my router such that the IP address for this parameter gets re-routed/re-mapped to "https://my-server" if the request originates from the LAN itself? My router's software supports LAN->Internet and Internet->LAN, but I don't see LAN->LAN.

share|improve this question
    
On StackOverflow.com, someone suggested that I try editing the HOSTS file. I tried this, but wasn't able to uncover the magic syntax. Also, I got flaky results when testing different variations. Sometimes my browser would konk out and couldn't resolve addresses until I revert all changes to the HOSTS file. –  Armchair Bronco Sep 6 '10 at 7:34
add comment

1 Answer

As suggested by someone on StackOverflow.com, the solution was to edit the HOSTS file. In my case, I needed to get my business partner to edit his HOSTS file after I changed the bugtraq:url on my end to:

https://my-server/svn/Bla...

Then he modified his HOSTS file as follows:

999.888.77.66 my-server

Works like a charm.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.