Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I login , it asks me "Would you like to enter a security context?"

I have SELinux enabled ..I'm using Fedora 12. How to resolve this?

share|improve this question
    
You haven't told us what your problem or questions is. –  d-_-b Sep 6 '10 at 13:50
add comment

3 Answers 3

Unless you have a specific need for SELinux I would just disable it, as it makes troubleshooting things more complicated.

1) Boot into single user mode: When you first start your computer, the GRUB screen (where you choose your Operating System) appears. Select the Fedora that you want to boot into, but press the a key instead of pressing Enter. append 'single' to the arguments there.

2) Then set SELINUX=disabled in /etc/selinux/config

3) reboot

share|improve this answer
    
I tend to set it to permissive, rather than disabled, because at least that way it logs stuff that has a different SELinux configuration to what is expected. –  Tom O'Connor Sep 6 '10 at 15:02
add comment

You could try something similar to this bug report by adding a < /dev/null

share|improve this answer
add comment
up vote 0 down vote accepted

Thanks everybody, the issue is with working of Pam.d with selinux enabled. I turned off pam.d features .its working now. though i need to re-look into /etc/pam.d/login instead of disabling it complete.

I have two choices - 1.disble selinux or 2.disable pam.d for login server. I chose 2.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.