Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a mail problem that I suspect is really a DNS problem.

My hosting company has apparently given me the subdomain li173-195.members.linode.com. I have another domain, woollymammothlabs.com, that points to the same IP as li173-195.members.linode.com.

When I send mail to jason@li173-195.members.linode.com, I get it. When I said mail to jason@woollymammothlabs.com, I get an undeliverable message.

What am I missing?

(I'm on Ubuntu and I'm using Postfix.)

Thanks, Jason

share|improve this question
where are you sending email from? –  Philip Reynolds Sep 6 '10 at 21:29

1 Answer 1

up vote 1 down vote accepted

It probably is a DNS problem.

When I search for the MX record for woollymammothlabs.com I get IP-address This is not the address of your server at li173-195.members.linode.com, which is Your mail for *@woollymammothlabs.com is delivered at

Change the MX record for woollymammothlabs.com then your problem will be solved (if your postfix configuration is correct).

share|improve this answer
Definitely DNS, your MX is set to m1.dnsix.com. This is a server farm wich adsresses in the address range. Fix your MX. –  BillThor Sep 6 '10 at 21:44
Fixing my MX record fixed it. Thank you! –  Jason Swett Sep 8 '10 at 16:10
You're welcome! –  Karst Lok Sep 8 '10 at 18:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.