Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an Amazon AWS instance that is hanging after a reboot. I can tell via the System Log in the AWS control panel that it is waiting for me to type in my SSL passphrase:

...
    [80G 
    [74G[ OK ]
 * Starting periodic command scheduler crond       
    [80G 
    [74G[ OK ]
 * Starting web server apache2  
Apache/2.2.8 mod_ssl/2.2.8 (Pass Phrase Dialog)
Some of your private key files are encrypted for security reasons.
In order to read them you have to provide the pass phrases.

Server xxxxxxxxx.xxx:443 (RSA)
Enter pass phrase:

So if I try to SSH into the server, I get a timeout. Is there any way I can get around this? Maybe disable apache from loading somehow remotely until I can SSH into it and do it myself?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

(Assuming EBS backed) My idea is that you're probably going to have to stop the instance and mount the EBS volume on another instance. Once mounted do something with that Apache SSL (disable from booting, disable SSL, etc.). Unmount that volume and bring up the EBS backed instance again.

share|improve this answer
    
Thank's Rob, that's probably the easiest solution. I've –  jnunn Sep 7 '10 at 18:13
    
@jnunn No problem. Your comment got cut off after "I've". –  Rob Olmos Sep 7 '10 at 19:34
    
Sorry, not sure what happened! "I've..." learned a lesson the hard way to remove the passphrase from my SSL certs on my protected servers--that should stop this from happening again. –  jnunn Sep 8 '10 at 13:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.