Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running a VMWare Server 2.0 with guest OS of Windows XP SP3. I have a NeatCo scanner hooked up via USB 2.0 port. Since VMWare server 2.0 now supports USB 2.0, I am able to get the scanner to be recognized by the guest OS. When I go to scan, it blue screens.

I checked the VMWare forums and most of the posts say to use USB 1.1 since older versions of VMWare don't support USB 2.0. I even updated the chipset drivers on the host PC to see if that helped - no good. Apparently it has to do with the packet sizes between USB 2.0 and 1.1. When I plug in the device, the guest OS suggests using a USB 2.0 port which means to me it's not recognizing the USB 2.0. I also checked the VMWare site for updated USB drivers, but nothing.

I would rather not have to get a USB 1.1 hub to work around this. Any ideas/experiences that may help? Thanks!!

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

When I plug in the device, the guest OS suggests using a USB 2.0 port which means to me it's not recognizing the USB 2.0

Original Answer: Are you sure you have USB turned on for your VM?

Ok, so it seems like your USB 2.0 on the host is showing up in your guest connected to VMware's UHCI (1.1) controller instead of the EHCI (2.0) controller in the virtual machine.

You could try a few things:

  • Make sure 'ehci.present = "TRUE"' is in your .vmx file for the VM. If you need to add it, shutdown the VM, change the vmx file, then restart it.

  • In Device Manager in the Windows guest, be sure you see an ECHI controller and that it appears to be working (no exclamation points or anything).

  • Look around the USB menus in the Server UI. There may be a way to connect a given host USB device to the EHCI controller if it's not already there. I don't have the Server 2.0 UI in front of me, so this may be way off.

share|improve this answer
    
Pretty sure, the "USB Controller" is in the hardware list in the VMware web access page and "Auto-Connect" is enabled. The scanner software does see the hardware in the guest OS. Also, the hardware appears in the drop-down for USB devices in the web access as well. –  John Virgolino Jun 2 '09 at 20:53
    
Sorry, I meant: Do you have the enhanced USB setting turned on in the VMware UI? –  kbyrd Jun 2 '09 at 21:44
    
Thanks for the clarification and pardon my ignorance but I can't seem to find this setting in the UI. I am sure I am missing something obvious. Can you point me in the right direction? –  John Virgolino Jun 3 '09 at 19:53
    
That fixed it! Adding ehci.present="TRUE" did the trick! Thanks for your help kbyrd! –  John Virgolino Jun 5 '09 at 0:12
    
Great! Did you import this VM from a previous version of a VMware product? That should have been added by default at VM creation time. –  kbyrd Jun 5 '09 at 1:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.