Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

There is an issue while installing some of the packages for python. They show 'No package available' message while trying to do yum install . They are these: python-psycopg, python-reportlab, graphviz, python-psycopg2, pychart, pydot, python-lxml.

The OS is CentOS5.5, python2.4 and postgres8.x. Its for installing Openerp. Their forum was not of much help.

Any help on it is much appreciated, thanks.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

CentOS doesn't have as many packages as other distributions and some of them are old, too. Add the EPEL repository and see if it has the necessarily packages.

The python-reportlab and python-psycopg packages are available in the RPMforge repository. I would recommend installing packages from this repository only if they're not available in CentOS or EPEL. This can be done with yum-priorities.

share|improve this answer
    
HMG!!. I have no words to thank you. Had been at this for nearly 2 days trying to set it up. 5 of them from the above got installed. Now just 2 more to go. python-psycopg, python-reportlab –  zapping Sep 9 '10 at 14:09
    
Unfortunately i need 2 more reputation to up vote your answer. :( –  zapping Sep 9 '10 at 14:10
    
@zapping select the check mark under the number of votes. –  Cristian Ciupitu Sep 9 '10 at 14:56
    
Got the python-reportlab installed with easy_install reportlab. But python-psycopg does not cannot find what it the command for it. –  zapping Sep 9 '10 at 17:24
    
@zapping: python-psycopg2 should be available. –  Cristian Ciupitu Sep 9 '10 at 18:45
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.