Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm on Windows using XAMPP and have Mercury Mail set up working fine for local mail. To get this working I need to use addresses such as, user@localhost

But it's a pain when I use email address validation in my scripts that require a properly formed email address, ie, with a domain extension like .com, .net, .co.uk etc on the end.

If I set up an address like user@local.dev, or even user@example.com, is there a place (ini, conf, hosts file or similar) where I can get this to 'map' to user@localhost?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Mercury "Configuration" menu option then "Alias..."

share|improve this answer
    
That was easy. Thanks! –  Owen Sep 10 '10 at 12:56
    
Not a problem... –  user48838 Sep 10 '10 at 13:50
    
I am running into the same problem using Drupal 7 amd XAMPP. I added the aliases and domains for localhost and localhost.com but I am still getting a Temporary error 249 (temporary MX resolution error). Where are MX records kept in XAMPP? –  John R Mar 24 at 23:57
    
It does not appear that XAMPP includes any actual email nor DNS servers. If your XAMPP configuration does include an email server (like the OP), then which email server is it? It will vary based upon the email server. –  user48838 Mar 31 at 12:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.