Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a domain controller running 2003 32bit standard, for some reason RDP has just stopped working to this machine. I have checked the firewall, the RDP service even symantec endpoint(note even turned endpoint off briefly to test). All seem to be working normally and allowing access.

When i try to do an RDP session to the DC all i get is the Error "this computer cannot connect to the remote computer"

I have tried to telnet to port 3389 and that works without issue.

Anyone have any ideas?

share|improve this question
    
Anything in the event logs? –  Coding Gorilla Sep 9 '10 at 15:25
    
How about a reboot? –  joeqwerty Sep 9 '10 at 15:30
    
Tried a reboot no luck, nothing in the event log either. –  Dave Sep 9 '10 at 16:04
    
Firewall issue? Have you double-checked any firewalls between machines? –  GregD Sep 9 '10 at 16:08
    
Have you tried connecting from a different PC to eliminate the PC you're using as the source of the problem? –  Coding Gorilla Sep 9 '10 at 17:17

3 Answers 3

What do the event logs say? What is the status of the Terminal Services Service? Have you tried bouncing the Terminal Services Service?

Start up a MMC running under an account that is an admin of that server by using runas /user:domain\adminuser mmc, and then add either the Services or the Computer Management mmc, and connect to the remote computer as opposed to localhost

share|improve this answer

I've seen this issue before on servers that run Routing & Remote Access (RRAS).

Other than that it might be a GPO setting that's being applied. Have you recently deployed any new GPO's?

share|improve this answer

I've seen this same issue randomly (although more often after patches are installed).

What I've done to resolve it is:

  1. Go into the Console and turn off remote desktop
  2. Reboot the server
  3. Go into the console and turn on Remote desktop

I've never been able to track down the why, but in a situation like you are describing that fixes it every time.

share|improve this answer
    
+1 It's frustrating that two decades into the Internet Age, things are still remedied with a reboot, but hey, it works. –  AndyN Sep 9 '10 at 21:11
    
@Andy yep, the really weird part is a reboot with RDP on does not fix it ... you've gotta turn rdp off then reboot –  Zypher Sep 9 '10 at 21:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.