Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was looking around but with no success. I published an application hosted as a RemoteApp on Windows Server 2008 (not R2). I have managed to turn Vista theme on the server itself but when run hosted application on the XP SP3 machine theme doesn't appear and the application uses standard Win 2008 Server theme.

When RDC to the server (using standard mstsc command) theme is enabled.

Is there some way to enable this theme within the application published by RemoteApp?

Regards Mariusz

share|improve this question

2 Answers 2

I doubt you will find something. The whole reason for a RemoteApp is that it feels like a native app running on the local machine. If this app then displays a Vista theme on XP, it is no longer behaving like all other native XP apps but looks different. Bad thing.

Also, I am not totally sure but I would guess that the Window decorations are actually done by the local Windows machine, not the remote server, a little bit like X11 does this.

share|improve this answer
    
Thanks for answer Sven. If what you saying is true the app should have at least XP theme (that is what I have on the local machine). Unfortunately it doesn't have even this. It looks like it uses win 2008 or win 2003 standard theme (grey square buttons as when you have your XP in the classic theme mode.) –  aristo Sep 10 '10 at 8:04
    
I have checked this closely and it looks like a RemoteApp uses Windows Server 2008 classic theme, not the XP classic theme. So, it looks like the UI is rerdered on the actual server; apart from the fact that it uses classic 2008 theme and not the vista one. –  aristo Sep 10 '10 at 11:42

This can be done. By the sounds of it, you've already enabled the Desktop Experience and started the "Themes" service. What will most likely happen is all newly created accounts will have the Aero theme, but pre-existing accounts stick with Windows Classic because their profiles are currently set to that theme.

What you need to do is force the Aero theme via GPO. You'll find this under User Configuration\Administrative Templates\Control Panel\Personalization\Force a specific visual style or force Windows Classic. Set it to Enabled and the theme path to %windir%\resources\themes\Aero\aero.msstyles.

Apply that GPO to the OU container that your users are configured in, and voila.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.