Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here's some background, I need to upgrade some VMs (for now just testing with one server) that runs RHEL4. My boxes are not connected to RHN, hence up2date doesn't get utilize. Since these boxes reside on a vmware server, I tried upgrading via my pxe server and that failed miserably. Redhat told me upgrades between major versions are not allowed. Ok, fair enough. I even tried tricking it to boot off PXEBOOT and attaching a kickstart file with just "upgrade" in the kickstart file - doesn't work. I ended up attaching the ISO via vmware's virtual client and it seems to be working right now.

My question, there's gotta be a way to do this over PXE and be able to choose "upgrade" instead of the defalt install. Booting off PXE doesn't allow me to see the anaconda gui where i can type "linux upgrade." Am I missing something in my pxeboot config?

Here's what I have:

kernel images/rhel5_i386/vmlinuz
append ksdevice=eth0 ip=dhcp initrd=images/rhel5_i386/initrd.img
share|improve this question
    
Are you attempting a clean install? Or an upgrade? What are you attempting to preserve? –  ForgeMan Sep 11 '10 at 3:13

1 Answer 1

up vote 0 down vote accepted

There is no clean upgrade option between major versions in anaconda. You can attempt to upgrade the packages yourself manually, but this is not recommended unless you have prior experience in doing so (and losing a machine or two in the process).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.