Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm in the process of replacing Apache with Lighty and I'm having some trouble.

The index of the page loads fine, but whenever I try to go into a subdirectory I will get a 403 forbidden error. It does not matter which directory.

I have tried setting the directories to 777 and I still got errors. I'm sure that the user that it is running under has access to the directory.

What should I do?

share|improve this question
    
Look in the error log to see what lighttpd says? –  Steve Kemp Sep 11 '10 at 8:47
    
The log doesn't say anything regarding permissions. –  Richard Sep 11 '10 at 12:59

2 Answers 2

Are you saying that lighttpd doesn't serve the directory listing, and gives out a 403 error instead? If that's the case, you have to add the following line to your config:

dir-listing.activate = "enable"
share|improve this answer

My Answer:

If you are using Debian's latest version of lighttpd then it is most likely as easy as.

[ Company -- root@web-server:~ ] # lighty-enable-mod userdir

Yeah, its as simple as that, I'm not sure if that command is from Debian's install of lighttpd or lighttpd it self. Please tell me what the answer is. :)

A PS1 that makes the command line much neater, includes color. :)

[\033[1;37m][ Affinity -- [\033[1;33m]\u[\033[1;37m]@[\033[1;32m]\h[\033[1;37m]:[\033[1;31m]\w[\033[1;36m][\033[1;37m] ] \$ [\033];$1\u@\h:\w\007]

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.