Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install iRedMail mail server, but when I run the installation script, I get the following error message:

The following packages have unmet dependencies:
  php5-common: Conflicts: php5-mhash
  php5-mhash: Depends: phpapi-20060613
              Depends: php5-common (= 5.2.6.dfsg.1-3ubuntu4.5) but 5.3.2-1ubuntu4.2 is to be installed
E: Broken packages

I'm not really sure what this means. I've tried reinstalling php5-common but that doesn't make a difference.

The full log is below. Thankyou for any help with this,
Dan.

< INFO > Installing package(s): apache2 apache2-mpm-prefork apache2.2-common libapache2-mod-php5 libapache2-mod-auth-mysql php5-cli php5-imap php5-gd php5-mcrypt php5-mysql php5-ldap php5-mhash php-pear postfix postfix-pcre awstats mysql-server-5.1 mysql-client-5.1 postfix-ldap slapd ldap-utils libnet-ldap-perl postfix-policyd dovecot-imapd dovecot-pop3d amavisd-new libcrypt-openssl-rsa-perl libmail-dkim-perl clamav-freshclam clamav-daemon spamassassin altermime libmail-spf-perl python-ldap libapache2-mod-wsgi python-mysqldb python-ldap python-jinja2 python-netifaces python-webpy python-ldap bzip2 acl patch cron tofrodos php-net-ldap2 phpldapadmin phpmyadmin Reading package lists... Done Building dependency tree Reading state information... Done apache2 is already the newest version. apache2-mpm-prefork is already the newest version. apache2-mpm-prefork set to manually installed. apache2.2-common is already the newest version. apache2.2-common set to manually installed. libapache2-mod-php5 is already the newest version. libapache2-mod-php5 set to manually installed. php5-gd is already the newest version. php5-gd set to manually installed. php5-mcrypt is already the newest version. php5-mcrypt set to manually installed. php5-mysql is already the newest version. mysql-server-5.1 is already the newest version. mysql-server-5.1 set to manually installed. mysql-client-5.1 is already the newest version. mysql-client-5.1 set to manually installed. bzip2 is already the newest version. acl is already the newest version. cron is already the newest version. phpmyadmin is already the newest version. Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: php5-common: Conflicts: php5-mhash php5-mhash: Depends: phpapi-20060613 Depends: php5-common (= 5.2.6.dfsg.1-3ubuntu4.5) but 5.3.2-1ubuntu4.2 is to be installed E: Broken packages < ERROR > Installation failed, please check the terminal output.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You should clean up your sources.list file. It seems that there are several package conflicts between PHP 5.2.6 and 5.3.2.

After you've removed the unofficial package source from your sources.list, run aptitude update and start the iRedmail installation script again.

share|improve this answer
    
Great, thankyou! :-) –  Dan Sep 11 '10 at 10:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.