Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am experiencing strange latency on my mac mini (os x 10.5.6) when I'm using my wireless internet. It has "full bars".

  • It only happens on the mac mini, not on the other two windows computers that are on the same wireless.
  • It goes away once I plug my mac mini into my vista box using ICS. (using a crossover cable).

The latency is:

  • ping stalls for 3 to 5 seconds before it runs like normal at 150ms.
  • Loading websites stall for 3 to 5 seconds then appear to load normally.
  • Oddly dig doesn't seem to stall at all, returns results in 150ms.

Any ideas how to trouble shoot this?

UPDATE:

Things have I already tried:

  • I have have done the standard reboot everything cycle.
  • I have powered off all wireless adapters in the entire house. (and nearest neighbor is 1/4 mile away)
  • I have turned off IPv6 (I have never had it on)

Other thoughts:

  • Could this be just the way OS X show wireless signal? (ie. show full bars when the signal isn't really that strong)

SOLVED:

My wireless router has failed. I replaced it with a new one and the problem is gone.

share|improve this question
1  
Try another AP? Do you see the ping stalls within your local network, or only to the internet? If all your network g or mixed b/g? If it's all g, set the AP to g only if you can. –  John McC May 5 '09 at 8:33
add comment

6 Answers 6

up vote 2 down vote accepted

Generally a good strategy for this type of network problem is to change-out or remove one component at time till it works. Or start with everything removed and add components until it fails.

After, as suggested above, rebooting everything, I'd try

  • Turning off the two Vista computers
  • Other AP's nearby? Try changing the channel
  • Baby monitor are apparently notorious - try a directional antenna on the AP and site it to maximise coverage for where your computers are.
  • Update the AP firmware
  • Make sure the Mini drivers/firmware are up-to-date
  • Try another AP
  • If all your network g or mixed b/g? If it's all g, set the AP to g only if you can

Do you see the ping stalls within your local network, or only to the internet? That migh give a clue about where the problem lies.

share|improve this answer
    
Can you add your comment in my question to this answer. The fix was to replace my wireless router. The problem has gone away. –  bentford Jun 8 '09 at 2:19
add comment

Reboot your computer, router, and cable modem.

share|improve this answer
    
Still, I stand by my answer. Have you rebooted the Mac Mini? Can you test it with a wired connection? –  Ben Alpert Apr 30 '09 at 22:33
    
Reboot of everything changes nothing. Changing to wired solves problem, that is my question. –  bentford May 1 '09 at 4:40
add comment

Have you got IPv6 enabled on the wireless adapter? If so, turn it off.

The delays you're getting sound consistent with the system trying to reach the far ends using IPv6 first, and then giving up and failing back to IPv4.

dig wouldn't do this, because by default your resolv.conf will only have IPv4 name servers listed in it.

share|improve this answer
add comment

I would suggest you look for sources of interference that share the same wireless spectrum. Some possible sources include

  • dect (cordless) phones
  • wireless doorbells
  • baby monitors
  • remote controlled cars

You get the idea, the A, B and G spectrums are not just for WiFi, they are available for any low power consumer level radio transmitters. If any of those devices are in your local area (hint, it might be in your neighbors house) then they may be stomping all over your WiFi signal.

share|improve this answer
    
I'll unplug my phones and see if that does it, I have no neighbors. –  bentford May 8 '09 at 11:02
add comment

Interesting, because most of the wireless issues I've seen have been on Windows clients (thus my assumption has been that Apple's wireless implementation is vastly more reliable and robust than Microsoft's - software-wise, but also hardware-wise if we're talking about Dell/vs/Apple hardware). I'll throw in a few punches and see if one helps beat-up the problem ;) :

  • Have you checked if encryption might be the culprit? (taking it out of the equation and checking would be a way to test this)
  • If you have Macports, it would be useful to run wireshark against your wireless NIC and analyze the communication on that device.
  • There's a question about Wireless Signal Strength at this Server Fault Page (Might be useful to try some of those tools to analyze the spectrum).

You mention pinging and using dig.

  • What are you testing against? (local or remote?)
  • DNS names (www.google.com) or IP x.x.x.x)

You've probably tried this already, but wouldn't hurt to delete and recreate the wireless network from the Airport interface control panel.

share|improve this answer
    
ping google.com has 5 second delay, then appears normal. ping 209.85.171.100 has no delay (this is one of google's ip addresses) Could it be DNS? I'm playing with it now. –  bentford May 8 '09 at 12:21
    
Haven't seen an update on this, any new news? –  l0c0b0x May 12 '09 at 22:34
add comment

Sounds like the issue is with your wireless router. If it has a proprietary "speed boosting" feature (generally protocols with juvenile names like Nitro- or Super-, or Turbo- ), you should disable it. Some protocols can affect network performance adversely, especially on non-Windows machines. I would log on to your router config page using a web browser and check it out. Those features only work when your network card also understands the "enhanced" protocol anyways (Eg: if Belkin makes both the router and the network card).

Are you using a single wireless router, by the way? If you have a wireless router plugged into a wired router, your problem could be related to "NAT over NAT" which you can fix by setting one of the routers to "modem mode" (AKA "bridge mode" in Apple parlance)

There's all sorts of things that it might be however, so you need to tell us the make/model of your wireless router. Once we have that, I will guarantee you a quick google will show lots of other people with the same issue. In rare cases, there are even routers that just plain do not work with particular cards. Come to think of it, wireless routers are pretty cheap these days, so you might dispose of your current router and get a new one. Problem solved ;-)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.