Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I setup a dns server/domain controller on a windows server 2003 box on my local network, giving it a fixed ip address of 192.168.2.9. I called the domain "toth.domain".

I then changed the preferred dns server on my Windows 7 box to 192.168.2.9 and tried to join the domain, however it can't find it. I can ping 192.168.2.9 just fine but can't ping either the dc's computer name "justin-dc" or its fully qualified domain name "justin-dc.toth.domain".

The error it gives when I try to join the domain is:

The following error occurred when DNS was queried for the service location (SRV) resource record used to locate an Active Directory Domain Controller (AD DC) for domain "toth.domain": The error was: "DNS name does not exist." (error code 0x0000232B RCODE_NAME_ERROR) The query was for the SRV record for _ldap._tcp.dc._msdcs.toth.domain Common causes of this error include the following: - The DNS SRV records required to locate a AD DC for the domain are not registered in DNS. These records are registered with a DNS server automatically when a AD DC is added to a domain. They are updated by the AD DC at set intervals. This computer is configured to use DNS servers with the following IP addresses: 192.168.2.1 - One or more of the following zones do not include delegation to its child zone: toth.domain domain . (the root zone)

Any help would be greatly appreciated. I'm a developer, not a sys admin, so please give details of how to do whatever you ask me to do, thanks! :)

share|improve this question
2  
Were there any issues when you ran DCPROMO? Did you elect to install DNS at the same time as the Active Directory binaries? –  MDMarra Sep 11 '10 at 17:31

1 Answer 1

up vote 0 down vote accepted

The error message suggests to me that the DC isn't using an AD integrated DNS server. If this is your only DC, you need to make sure that it is using itself for DNS and not anything else. In the DNS servers list, set 127.0.0.1 as the primary and leave the secondary blank if you have no other AD DNS servers.

share|improve this answer
    
Yeah, the issue was that I changed the preferred DNS server for my wireless adapter that was disabled, not my active one, doh! –  Justin Sep 12 '10 at 14:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.