Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a network in NY where I'm trying to migrate their MS Exchange Server to Rackspace at the DFW Datacenter in TX. The NY network, seemingly randomly, developed a strange DNS issue. The NY office AD domain is foo.com. www.foo.com, shop.foo.com, etc are hosted outside the NY office and are working properly for the outside world. Inside the office all subdomains are not accessible by a browser.

The DNS records to forward the requests are properly installed in MS DNS on the primary server within the NY office. If I NSLOOKUP, it reports the correct outside IP's for www., shop., etc.

I've taken down their ISA Firewall temporarily and still not working. I've taken down their Barracuda Spam Firewall and still not working.

And the weird twist is the browser doesn't immediately report that it can't find the site (www., shop., etc). It will attempt to load the page for about 3 minutes, sometimes will partially load and then fails.

Suggestions? Ideas? I need to fix this issue before I change the DNS for the Exchange Server, or the employees in the NY office won't be able to access mail.foo.com tomorrow morning.

Thank you,

-Ted-

UPDATE

  1. mobile.foo.com seems to work, but shop.foo.com still does not, and they are on the same server outside the office.

  2. It seems the problem is only affecting HTTP.

  3. If I access shop.foo.com on an alternate port (say telnet to shop.foo.com 21) it properly brings up FTP in the cmd prompt.

UPDATE

Upon further review, it looks like it's only www.foo.com that is malfunctioning within the office. the other websites (shop., etc) are using resources from the www.foo.com server and are causing the page time-outs and partial loads.

NSLOOKUP does continue to work properly for www. though. Ideas? Thoughts?

share|improve this question
    
Have you tried ipconfig /flushdns? Afaik, nslookup ignores the local DNS cache. –  gravyface Sep 12 '10 at 17:36
    
Yes, but I will try it again. I've changed ISA firewall settings recently. This thing is driving me nuts. Thanks for the great tip! –  user54044 Sep 12 '10 at 17:50
add comment

1 Answer

Are you using any kind of a proxy server? If the web browsers are using the proxy without proper proxy exception rules, and the proxy is outside your internal network (or uses external DNS) then you might see an issue of this type.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.