Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I use Application request routing in my farm environnement.

I got 2 ARR server and 2 IIS server in my farm. I configure my routing to load balance request even to my iis server, but when i look worker process in my farm server, only one server receive all the request and the other server is idle.

Could someone tell my if i am rigth or not but ARR suppose to load balance the request even on all my farm server if i configure it to do that rigth ?

My load balance configuration is Weigthed total traffic,(even distribution). My server affinity is set to Client affinity, Use host name, ignore subdomain

share|improve this question
    
In your server farm, double click Load Balance. What algorithm are you using? –  Dave Holland Sep 13 '10 at 2:02
    
Actually is Least response time –  Cédric Boivin Sep 16 '10 at 18:06

2 Answers 2

I could make a rather long post, detailing all the possibilities causing this, or I could give you an extremely useful link that walks one through the entire process. I'll do the second thing!

http://blogs.msdn.com/b/webdevtools/archive/2009/02/17/iis7-load-balancing-routing-module-now-available.aspx

If you find that you cannot solve your problem with the steps listed in this article then feel free to respond with what problems still plague you.

share|improve this answer

Try "Weighted round robin" and fire at least 2 requests then check whether your servers receive the requests or not.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.