Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to set up a user "ftp" so they can upload and download files in my /home/httpd/mysite/public_html directory.

All files in public_html are owned by user ftp and in group www-data so the ftp user looks like so:

uid=108(ftp) gid=33(www-data) groups=33(www-data),65534(nogroup)

When I try to connect via an FTP client I get

530 Login incorrect. ftp: Login failed.

What do I need to uncomment/add to the proftpd.conf file to make this work?

share|improve this question
add comment

3 Answers

Just had this problem with Ubuntu 12.04.2 and ProFTP. I had my FTP user's shell set to /bin/false and ProFTP wouldn't allow that to connect (it showed Error 530).

What I did was followed I uncommented this on my /etc/proftpd/proftpd.conf:

RequireValidShell Off

And I also added /bin/false to my /etc/shells file.

Restart ProFTP and you're good!

Hope this saves someone time.

share|improve this answer
add comment

Check the value of AuthAliasOnly. If it's set to on and you've not set a suitable UserAlias then you will get login rejected.

Setting AuthAliasOnly off should fix that problem.

share|improve this answer
    
Tried that but no luck. So I ended up reinstalling and adding a new user ftpuser, and it works. –  kidrobot Sep 14 '10 at 23:54
add comment

The error is mainly get when the user has a shell that is not listed in /etc/shells Make sure the /bin/false is declared into /etc/shells

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.