Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I posted this query on staackoverflow main but it was suggested I should ask here. Sorry for the non-openID login, but as you can see, I'm having some issues.

In short:

A couple weeks ago I noticed I could no longer log in with my URL delegating to an underlying OpenID provider (getopenid). I checked their server and it was returning and error, so I switched over to myopenid.com. I'm still not able to log in anywhere though.

I get openid endpoint not found. I'm using these elements:

<link rel="openid.server" href="http://www.myopenid.com/server" /> 
<link rel="openid.delegate" href="http://fberriman.myopenid.com/" /> 
<link rel="openid2.local_id" href="http://fberriman.myopenid.com" /> 
<link rel="openid2.provider" href="http://www.myopenid.com/server" /> 
<meta http-equiv="X-XRDS-Location" content="http://www.myopenid.com/xrds?username=fberriman.myopenid.com" />

Is it a mistake in the tags (copied from myopenid's help pages, just to be on the safe side), a wordpress related problem or something on the server? I can't get the openid test page to even return me an error other than the 'no endpoint found'. Any pointers greatly appreciated (I'm no server admin, mind you).

I'm trying to use it at stackoverflow (all sites) for a good reference point.

This test site also says 'no endpoint found' http://test-id.org/OP/Sreg.aspx I've tried with just openid tags, openid2 tags and both. Also without the meta http-equiv tag. None of these combinations work - so I'm at a loss and am thinking it must be something with my server?

Possibly the wrong headers sent?

Would appreciate any pointers or testing I can do to report the issue back at least.

The only thing I can think I have done personally is upgrade from wordpress 3.0.0 to 3.0.1, but I haven't found anything online suggesting this upgrade causes any issues.

Thanks in advance

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Some things to check:

  • Are you connecting to the internet via a proxy?
  • Do you block any cookies? Third-party cookies?

FWIW, these are the headers I use with Verisign PIP labs and they work fine:

<link rel="openid.server"
  href="http://pip.verisignlabs.com/server" /> 
<link rel="openid.delegate" 
  href="http://docunexter.pip.verisignlabs.com" /> 
<link rel="openid2.provider" 
  href="http://pip.verisignlabs.com/server" /> 
<link rel="openid2.local_id"
  href="http://docunexter.pip.verisignlabs.com" /> 
<meta http-equiv="X-XRDS-Location" 
  content="http://pip.verisignlabs.com/user/docunexter/yadisxrds" /> 

Good luck!

share|improve this answer
    
Hello, Thanks. I've just tried again on an entirely separate connection and it's still not working, plus I can sign in with the underlying delegated ID. So it leads me to believe it is something on my server/implementation side. –  Phae Sep 13 '10 at 12:48
    
Your headers look good to me... can you post your openid so I can take a look at the full HTML? Mine is openid.albertlash.com/openid. –  Docunext Sep 13 '10 at 13:00
    
They're as they are in the example. I use fberriman.myopenid.com that delegates to fberriman.com –  Phae Sep 13 '10 at 13:04
    
I just tried it against your openid - since yours would also work in my header (your open id, my header - should have taken me off to your end point). The service checker returns no openid for that also - so I'm certain it's not the openid tags now - it's either something in the surrounding markup or server configuration. –  Phae Sep 13 '10 at 13:20
    
I've just sorted it. I'm not sure if I deleted this by mistake or what, but I've just noticed I accidentally removed my head starter element. Unsurprisingly, I'm guessing that wasn't helping the page parse very well. Thank you for taking the time to look at this - but it was simple user error! –  Phae Sep 13 '10 at 13:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.