Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to login to Superuser with OpenID, and it generates a request like this:

telnet phor.net 80
GET /professional HTTP/1.0
Accept:text/html,application/xhtml+xml,application/xrds+xml` 

And my Apache server gives the error:

406 Not Acceptable: 
An appropriate representation of the requested resource /professional 
could not be found on this server. Available variants: 
professional.php, type  application/x-httpd-php

If a normal web browser hits the site, content negotiation correctly selects professional.php as the resource for this request. Is it possible to serve this same file to superuser?

share|improve this question

closed as unclear what you're asking by kasperd, Ward, mdpc, Katherine Villyard, Jenny D Feb 11 at 7:47

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

Did you try adding application/x-httpd-php to the accept portion of your request?

share|improve this answer
    
Yes, that fixes the problem. But I cannot control the client's (Superuser.com) request, I can only control my server's response. – Full Decent Sep 13 '10 at 22:21

Solution

AddType text/html php 

In my /etc/apache2/sites-enabled/*

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.