Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My school's network is on the domain ".edu" let's just say "X.edu" and my laptop's name is some sort of serial number, let's say SERIAL. So my laptop's fully qualified name is SERIAL.X.edu, this is my school laptop. When I go home (I live off campus), I have 4 computers named Inky, Blinky, Pinky, and Clyde (the pacman ghosts) and they're all on WORKGROUP, the default workgroup all running Windows XP. The laptop runs Windows 7. The 4 ghosts are physical computers, but I just call them my ghosts.

When I ping clyde or any other ghost, (simply running "ping clyde" in cmd), it attempts to ping clyde.X.edu and even finds an IPv4 address for it (it's the same IP address regardless of if I'm pinging inky, blinky, pinky, and clyde, and it's the wrong IP address) and all requests time out. These 4 ghost computers all can only be used by remote desktop. There's only network and power plugged into each ghost computer and I can connect to them using any computer not on my school's domain simply by trying to RDP using the ghost computer's name.

The network is pretty basic. Coaxial from wall to modem, ethernet from modem to wireless router, 4 hardwired connections from the wireless router to the 4 pacman ghost computers, and wireless to the rest of the house. Simple WEP password, SSID is broadcast, the laptop is connected and working fine on the internet.

What settings can I make to my school laptop (without removing it from the school's domain or changing it's name) can I change to allow me to directly connect to my ghosts by computer name? I'm aware I could add inky/blinky/pinky/clyde to the hosts file on my school laptop (given the IPs below), but I feel that's just a duct tape fix, not a real fix.

DHCP on the wireless router starts at 192.168.1.100 and goes for 100 entries. My ghosts obtain static IPs:

  Inky is 192.168.1.50
Blinky is 192.168.1.51
 Pinky is 192.168.1.52
 Clyde is 192.168.1.53

The school laptop receives whatever IP it's issued, it's dynamic.

share|improve this question

1 Answer 1

Check your wireless router and see if it has somewhere in the DHCP settings where you can set the DNS search suffix.

The problem that you have is that your home network currently does not have an internal DNS suffix in which to search (e.g. myhome.lan).

If you can set your DHCP server to assign its clients a suffix when they request an IP address, you can then configure the suffix search list on your school PC to search for both *.X.edu, and *.myhome.lan. You could also start addressing your machines via a full DNS name like pinky.myhomelan.

Of course, this depends on your home router supporting it. But many do.

share|improve this answer
    
That sounds like a good place to start! –  dunxd Sep 14 '10 at 11:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.