Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

ve recently switched IIS6 to 32 bit mode and none of my sites (framework 2.0 and 4.0 ) are running now. it says "Service Unavailable"

Here is what I've done: followed the steps from : http://support.microsoft.com/kb/934162 Any help?

Answer: (1) Convert the 64bit w2k3 to 32 using above article. (2) aspnet_regiis -i for .net 2.0 and 4.0 both (3) restart (4) you will notice website properties in IIS will not have ASP.NET TAB (5) download iis6 utility to change .net framework version (6) configure reporting server and set the websites for the same to asp.net 2.0 (7) all is done well and working fine

share|improve this question
    
How did you do the switch? What did you do to fix it? Right now this is too broad. –  TomTom Sep 14 '10 at 12:18
add comment

1 Answer

up vote 0 down vote accepted

Do you have an ISAPI Filter or other module that references a 64-bit DLL? That's the most likely cause. Try pulling out all of your filters and handlers to get a good test page. You can also create a new app pool and create a simple 'hello world' page to confirm that it's not something at the server level. Then start adding back parts until you narrow down the cause.

If you haven't already, check Event Viewer for clues too.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.