Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install and update agents using VMM 2008 R2. My VMM Service account has admin access to the VMM server and the host servers. Logged in as the service account, I can copy files from the VMM server to \hostserver\admin$ all day long.

When I try to install or upgrade an agent, I get an error saying "Agent installation could not access the ADMIN$ share on server FOOBAR"

I also enabled tracing for VMM and the trace logs are showing that the copy to admin$ is failing. However, I can manually access admin$ with the same account that I am using to run the job and with the VMM service account, so I don't think its a permissions/access issue.

Any ideas what else I could do?

share|improve this question
up vote 1 down vote accepted

I've been working with MS on this issue and it looks like it is a problem with the installer. Reviewing the logs, I can tell that the installer actually tries to copy over the x86 version of vmmagent.msi, which works fine, then use WMI to delete the file, and then tries to copy over the x64 file.

Both are named vmmagent.msi. The installer is getting a notification that the file has been deleted when in fact the deletion is not complete. When the x86 version is there and the installer is copying over the x64 bit version, the "Access Denied" error is popping up.

Until this is resolved in VMMM, I'll just install the agent manually with a script.

share|improve this answer

The domain machine account of the SC VMM Server has to be added to the Local Admins group on the Host Server.

share|improve this answer
it is already. I saw that a while back and thought it might be the fix but still no go. – Andy Schneider Sep 14 '10 at 19:24
Try enabling auditing on failed authentication events and see what shows up in the even log of the Host server. It should say exactly what account it's trying to login with, and why it (generally) failed. – Chris S Sep 14 '10 at 20:22
So what is really weird is i can see in the trace logs that it was able to successfully copy over the x86 installer bits, try to run them and fail, delete the bits, and then try to copy the x64 bits and fail on the copy. – Andy Schneider Sep 14 '10 at 21:02
Nothing glaring appears in the audit logs – Andy Schneider Sep 14 '10 at 21:34
That's a tough one. Have you tried installing the agent manually to see if the installation works at all? – Chris S Sep 15 '10 at 12:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.