Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

About a month ago I installed a security update that had new Kernek 2.6.34.x from 2.6.33.x) on Fedora 13, this is when the problem occurred for the first time.

After the install computer would not boot at all, black screen without any visible hard drive activity (I gave it good 30 minutes on black screen, before took actions)... I poped in installation DVD and went in rescue mode to change back the boot option to old kernel (was just a guess where the problem was). After restart computer loaded just file, took a long time for it to start because of SELinux targeted policy relabel is required. Relabeling could take very long time depending on file size. I assumed that the update got messed up somehow and continued working with modified boot option.

Couple of days ago, there was another kernel update. I installed it and same problem as before. This rules out corrupted update theory... black screen right after 'BIOS' screen before OS gets loaded. I had to rescue system again... Below is copy of my grub.conf file. I am fairly new to LINUX (couple of years of experience), mostly development and basic config... nothing crazy.

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/mapper/vg_obalyuk-lv_root
#          initrd /initrd-[generic-]version.img
#boot=/dev/sda
default=2
timeout=0

splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.34.6-54.fc13.i686.PAE)
    root (hd0,0)
    kernel /vmlinuz-2.6.34.6-54.fc13.i686.PAE ro root=/dev/mapper/vg_obalyuk-lv_root rd_LVM_LV=vg_obalyuk/lv_root rd_LVM_LV=vg_obalyuk/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
    initrd /initramfs-2.6.34.6-54.fc13.i686.PAE.img
title Fedora (2.6.34.6-47.fc13.i686.PAE)
    root (hd0,0)
    kernel /vmlinuz-2.6.34.6-47.fc13.i686.PAE ro root=/dev/mapper/vg_obalyuk-lv_root rd_LVM_LV=vg_obalyuk/lv_root rd_LVM_LV=vg_obalyuk/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
    initrd /initramfs-2.6.34.6-47.fc13.i686.PAE.img
title Fedora (2.6.33.8-149.fc13.i686.PAE)
    root (hd0,0)
    kernel /vmlinuz-2.6.33.8-149.fc13.i686.PAE ro root=/dev/mapper/vg_obalyuk-lv_root rd_LVM_LV=vg_obalyuk/lv_root rd_LVM_LV=vg_obalyuk/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
    initrd /initramfs-2.6.33.8-149.fc13.i686.PAE.img

I like my system to be up to date... Let me know if I can post any other files that can be of help.

Has anyone else had this problem? Does anyone has any ideas how to fix this problem?

p.s. Anything helps, you ppl are great! thx for ur time.

share|improve this question
1  
Have you considered reporting a bug? Also remove rhgb quiet from the boot command line and start in text mode (runlevel 3). –  Cristian Ciupitu Sep 14 '10 at 20:35
    
I wanted to check with experts here first, before reporting a bug. I will change option back to default without rhgb quiet and update my post on what happens. Thx. –  Alex Sep 14 '10 at 20:49
    
This is a question better asked on fedoraforum.org - you will get all the Fedora desktop people to help, this site is mainly for server things. –  troyengel Sep 15 '10 at 0:04
    
@Cristian - thx for your comment. It helped me see messages describing the problem, I was able to use that info to find bugzilla.redhat.com/show_bug.cgi?id=629203. If you post your comment as answer, I will mark it as correct! Thx a lot. –  Alex Sep 15 '10 at 13:28

1 Answer 1

up vote 1 down vote accepted

Remove rhgb quiet from the boot command line and start in text mode (runlevel 3) to have a better idea of what's going on. Then consider reporting a bug.

P.S. It seems that someone else has already reported this bug.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.