Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need run a local demo of a program that have a harcoded path to a .mbd database in the format:


I can't change the name of local machine because is needed for logging purposes.

Thanks in advance

share|improve this question
up vote 0 down vote accepted

Install VMWare Workstation on your computer. Create a new virtual machine. Install Windows.(Remember to use the computername you need) Problem solved (I hope)

Little bit more work but worth the effort.


share|improve this answer
Thanks for your help Clyde, I used Virtualbox with network in bridged mode and works fine !!! :-) – Leonardo Sep 17 '10 at 3:17


Open the Hosts file in notepad. Add a line which says: NewNameMycomputer

I Hope this works for you.

You can add more lines as above to link your ip address to multiple names.

share|improve this answer
Note: change the IP address in the above answer to your local IP address, or to be save, for the loopback adaptor – Mark Henderson Sep 15 '10 at 12:32
Yes i should have mentioned that. Sry but i was in a hurry ;) BTW I think on Windows 7 you might have to fiddle around with security settings on the folder you are sharing if you are asked for a username and password. Maybe something like everyone with all permissions. – Clyde Veldkamp Sep 15 '10 at 13:14
I tried it and actually asked me for username and password, but do not accepted (excuse me my english) – Leonardo Sep 15 '10 at 14:24
That is probably because the login for example is not oldmachinename\administrator but newmachinename\administrator, maybe you try to set security/share settings to permit everyone or add a new user corresponding to newmachinename or maybe an anonymous account. Remember it's not an out of the box solution. I guess windows 7 is more frantic about security than Windows xp. – Clyde Veldkamp Sep 16 '10 at 9:36
i posted another solution that should work. – Clyde Veldkamp Sep 16 '10 at 10:01

If your server is running linux with Samba, you could redirect SharedFolder to another server by setting the "msdfs proxy" parameter to another share (on another computer) in your config.

msdfs root = yes
msdfs proxy = \\OtherComputerName\SharedFolder

If it's Windows I can't help you with your configuration, search for MSDFS (MicroSoft Distributed File System).

share|improve this answer
Thanks for the reply, guided me to find the following information…, however the computer I need to do the test is Windows 7 and I don't found how to apply – Leonardo Sep 15 '10 at 11:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.