Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Am running SQL Server 2000 on Windows Server 2003 Standard. In perfmon, have access to the "SQLServer:Databases" object, however, only about HALF the databases are listed as instances.

I detached a few of the databases (and reattached) to no avail.

Any thoughts? Thanks!

share|improve this question

1 Answer 1

Yes, I do know that with SQL2005 and SQL 2008 that , on Windows Server 2008, a auth policy error will be thrown when attaching a previously detached database. Its a know bug/feature issue. I would bet that SQL2000 doesn't know how to communicate this in the modern SQL 2003 operating system.

In order to successfully attach you need to make sure that file permissions on the .mdf and .ldf file are perfect. Specifically, make sure that the user you are currently logged in as is assigned literal permissions to the directory where the .ldf and .mdf reside. This may be the solution and if it doesn't work, just play around with file permissions and also keep in my what user account the SQL server is running as.

share|improve this answer
    
Hi, Checked the permissions and everything here looks ok. Does anyone know which registry entry perfmon uses to populate the instance lists? Was thinking that might be a place to check... –  Chris Anton Sep 17 '10 at 12:48
    
oh i see. i guess my answer was a little off-base. there could still be some kind of compatability issue between the old SQL2000 and Windows 2003. there is a huge difference in the age of those products and SQL2000 hasn't had a service pack in a long time. –  djangofan Sep 17 '10 at 16:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.