Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Full Error Message:

System.Security.SecurityException: Request for the permission of type System.Web.AspNetHostingPermission, System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 failed.

OS: Windows Server 2008 R2.
Web Server: IIS 7 with IIS 6 compatibility & metabase installed.
.NET: One website running fine under 2.0, this website is in 1.1

A common solution I've found is when the problem relies on files being on a shared network drive. This is not the case, all website files are on the C: drive of the server.

The ASP.NET 1.1 site did work fine on Windows 2003, however moving the site over to the new server has caused this issue.

All the files are accessible by the Web Service account and system accounts via the Windows File Security permissions.

In the site web.config under <system.web> we have:

<trust level="Full" />

3rd party libraries referenced in the bin folder:

DynamicPDF.Generator.dll DynamicPDF.Merger.dll EeekSoft.Web.PopupWin.dll NetSpell.SpellChecker.dll TTWebVBVS.dll

I'm at a loss as to what could be the issue, my intuition says the <trust level="Full" /> should have solved this, but it obviously hasn't.

If anyone has any ideas how this issue could be solved, I would appreciate it!

share|improve this question
up vote 1 down vote accepted

Solved my issue.

In the application pool for ASP.NET 1.1, I changed LoadUserProfile from FALSE to TRUE.

Somehow that worked, not sure why.

share|improve this answer
Changing LoadUserprofile from FALSE to TRUE works for me too. Thanks! – user58384 Oct 27 '10 at 4:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.