Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Our small business LAN has several (Windows XP) PCs that are experiencing very slow internet speeds. LAN speeds appear to be fine, testing around 90 Mb/s using iperf, but seeing internet speeds around 0.2 Mb/s. Most computers on our network are getting internet speeds around 2.0 Mb/s (we have two slow Qwest DSL connections going into a Linksys RV082 router with dual WAN ports).

This problem first started when we replaced an old 10 Mb/s hub with a new 100 Mb/s unmanaged switch (Cisco SR224G). The slow internet speed can be eliminated by putting the old hub back in line with the slow PCs. But going directly into either the switch or the router causes the slow internet speed to come back. Note that in either configuration, LAN speeds inside the network are great: 90 Mb/s (or 9 Mb/s when going through the old hub as you would expect).

What could the old hub (OvisLink Ethernet Hub 16+) be doing to the traffic that would so dramatically speed up our internet traffic to certain PCs? What can I check for to track down the cause?

Update:

We've run several virus/malware scans on both. These are relatively new (3 yrs old?) PCs with 100 Mb LAN ports built in to the motherboard. I haven't checked the duplex settings but if this were the problem, or if the cabling in the building is bad, how am I getting 90 Mb/s internally?

Also tried forcing one client NIC to 100-Full or 100-Half instead of Auto-detect. This didn't make a difference, the problem is still very reproducible.

Another clue: ping packets seem to be as fast as usual, but TCP is slow. At least on speedtest.net the initial ping is 75ms, right in line with what we usually get, but then the page just freezes up and doesn't even move. On occasion it does work through to the end where the results are something like 0.1 Mb/s.

share|improve this question
1  
Are these PC's older? I'm thinking maybe the older NIC's in the PCs just aren't playing nicely with the newer switch. –  Coding Gorilla Sep 17 '10 at 20:13
    
Yes, a new network card turned out to be the answer. –  jacobsee Oct 25 '10 at 22:32
add comment

4 Answers

Have you done any traffic captures on stuff crossing that 10MB hub? Perhaps one of those old computers is virus infected, and when you give it more bandwidth it simply uses it all?

Basically in this case the hub could be acting as a traffic limiter. Preventing attached computers from using more then bandwidth then what it will allow.

share|improve this answer
1  
And a laptop with WireShark on that hub would let you see traffic on all segments attached to that hub so you should be able to narrow it down pretty quickly. –  gravyface Sep 17 '10 at 20:39
add comment

It also could be that the cabling you have in the building is not done properly, or runs in-line with sources of interference basically causing a lot of problems when trying to connect at 100mbt full-duplex instead of 10mbt half-duplex. You might also want to check those machine's network cards & set the connection speed & duplex settings manually. Some network cards do not auto-negotiate very well.

share|improve this answer
add comment
up vote 0 down vote accepted

A new network card in the PC turned out to be the solution. Not sure why, but something in the motherboard's ethernet port was slowing down TCP traffic to the internet. Motherboard is an Intel D845GEBV2 and the new card is an Intel PWLA8391GT

share|improve this answer
add comment

One suggestion is to see if the Windows XP NIC's are set to auto-negotiate. If they are, change them to be set to 100MB Full. Auto-negotiate does work on a Gigabit network but can experience errors on a 100MB network. You may be experiencing a large number of errors on your switch resulting in latency.

share|improve this answer
    
Just tried that on one system. Moved his connection from the old hub to the new switch and set his NIC to 100-Full and 100-Half. In either case we see the very obvious slow down, speedtest.net wouldn't even fully load. Went back to the old hub and set it back to auto. It detected at 10 Mb and speedtest loaded right up. Weird. –  jacobsee Sep 17 '10 at 21:24
1  
You should not change the auto-negotiate setting on a machine unless you also set it on your switches. If you disable negotiation on 1 side of a 100mb you will get a duplex miss-match almost every time. –  Zoredache Sep 17 '10 at 21:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.