Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have ubuntu os installed in oracle virtualbox. The network interface is not working after I changed the mac address of it in the virtualbox settings and I'm getting following error.

Blockquote

eth0: error fetching interface information: Device not found

Blockquote

any tips?

share|improve this question

closed as not a real question by MDMarra, sysadmin1138 Aug 14 '11 at 19:20

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

1 Answer 1

up vote 0 down vote accepted

  1. disable nic 1 and create new or 2. shutdown guest os, edit ~/.VirtualBox/Machines/GUESTNAME/GUESTNAME.xml, section Hardware Adapter NN

        <Adapter slot="0" enabled="true"
    

    MACAddress="080027B7E4E9" cable="true" speed="0" type="Am79C973"> or 3. if you have snapshot, rollback to early snapshot

share|improve this answer
    
I added net interface eth0 again but ip address is not assigned to this interface. I even tried 'dhclient', it kept on requesting ip but finally it didn't. –  user53864 Sep 19 '10 at 7:17
    
Can't I do host to guest networking with NAT enabled. Because I long ago tried virtualbox network mode to Bridged and I could do host to guest networking but I couldn't access internet on the guest! –  user53864 Sep 19 '10 at 7:33
    
It's ok if have any tweak to access internet with bridged mode so that I can have both host-guest networking and internet. –  user53864 Sep 19 '10 at 7:49
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.