Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Trying to compile corona on CentOs5.

When I run ./configure I get

checking how to run the C++ preprocessor... /lib/cpp
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.

Tried downloading an rpm and it said missing dependencies

libgif.so.4 is needed by corona-1.0.2-2.i486 rpmlib(PayloadIsLzma)

Although after looking at that, I am guessing I downloaded an rpm not for centos5?

(Ugh, I can never get pre/code to work :|. Even though it looks fine in the preview)

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

You need g++ compiler. To install: yum install g++

share|improve this answer
    
"No package g++ available." What repo can I find it in? –  Will Sep 19 '10 at 15:10
    
Ah, it is "gcc-c++". –  Will Sep 19 '10 at 15:25
    
"SaveTGA.cpp:2:17: error: png.h: No such file or directory" –  Will Sep 19 '10 at 15:26
    
install libpng and libpng-devel –  bindbn Sep 20 '10 at 1:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.