Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have setup IIS on my xp machine and have setup a default homepage (that comes with the IIS installed). It is a help page I think.

when I access the page with http://localhost it works fine (IE/Chrome or FF) but when I access it using http://hostname it prompts for a loging/password and works when I enter my domain id and password on the intranet.

I have ensured that "anonymous access" is enabled in the properties window of the default site and "websites" node.

I searched stack overflow for similar queries but some indicate I need to change the IE/FF settings to allow "integrated security" etc and some suggest to look at the "log file".

I don't want to change the IE setting and there is nothing unusual in the log file of the IIS Server.

Can anybody help me figure out why this is happening?

thank you sb

share|improve this question

migrated from stackoverflow.com Sep 19 '10 at 13:32

This question came from our site for professional and enthusiast programmers.

    
Step one is for you to see exactly what is requiring authentication. For this you can install Fiddler and use it to monitor the traffic from your browser to the web server. Once you see exactly which request is causing the authentication then you should update your question with that information. –  Jeff Apr 1 '10 at 23:25

3 Answers 3

You should look at the configuration of your IIS protection.

Although it seems like you are connecting to the same system, using "localhost" from a browser on your IIS server, you are connecting to 127.0.0.1.

When you connect to the http://hostname URL from another system, you are connection to the systems external IP address.

1. The client requests a resource on the server.

2. The IP address of the client is checked against any IP address restrictions in IIS. If the IP address is denied access, the request fails, and a 403 Access Forbidden message is returned to the user.

3. The server, if configured to require it, requests authentication information from the client. The browser either prompts the user for a user name and password or offers this information automatically.

Access Control in IIS 6.0 (IIS 6.0)

share|improve this answer

You need to add http://hostname in Internet Explorer, Security for local intranet.

Steps:- Go to IE --> Tools --> Internet Options --> Security --> Local intranet --> Sites and add

share|improve this answer
    
How would configuring IE change the permissions on the IIS server? –  benc Sep 18 '10 at 14:53
  1. Add Admin user with password
  2. Go to wwwroot props
  3. Give this user a full access to this folder and its children
  4. Change the user of the AppPool to the added user using this article http://technet.microsoft.com/en-us/library/cc771170(v=ws.10).aspx
  5. Change the User of the website using this article http://techblog.sunsetsurf.co.uk/2010/07/changing-the-user-iis-runs-as-windows-2008-iis-7-5/ Put the same username and password you have created at step (1).

It is working now congrats

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.