Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to enable binary logging on my Windows based MySQL server. I can enable it on my Linux system, but I keep getting errors when trying to invoke mysqld.exe with the --log-bin option.

c:\Program Files\MySQL\MySQL Server 5.1\bin>mysqld.exe --log-bin[=c:\mysqlbinlog]

100919 15:45:29 [Warning] '--default-character-set' is deprecated and will be re moved in a future release. Please use '--character-set-server' instead.

Edit: Turns out I had forgot to restart MySQL server. I thought I had, but some other syntax errors caused it to fault, which I in turn corrected. Thanks for replies, not sure how I should mark this as solved.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

This is not an error message, it is just a warning. Your binary logs should work just fine. I would recommend to keep the binary logs somewhere else, probably together with the databases, and definitely not in the root of the C:\ drive.

If you want to get rid of the warning message, have a look at your server config file and change the option for the "default-character-set" into one using "character-set-server".

share|improve this answer
    
1) That is what I initially thought as well, but when I run "show binary logs" through the MySQL command line client, I get "ERROR 1381 (HY000): You are not using binary logging" 2) It's not an actual live database, it's just for testing purposes, so that's why I'm using such a path. –  Anonymiusen Sep 19 '10 at 15:47
    
Did you any write operations before "show binary logs"? –  lg. Sep 20 '10 at 7:21
add comment

try using forward slash in the path c:/mysqlbinlog

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.