Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

This issue has been plaguing me for a few days now and I can't seem to make any headway. This will be my first test of the serverfault community.

We have an HP server with two SCSI attached tape drives. The server has Backup Exec 11d installed AND Microsoft DPM 2007. Backup Exec uses one of the tape drives and DPM 2007 uses the other. This has worked for the past few months without an issue. Over the weekend, it seems something changed (I have no idea what) and things stopped working.

Here is the current situation:

  • BackupExec sees both drives and thinks that they are fully operable. Backups performed with BackupExec work fine.
  • DPM only sees one of the two tape drives (it used to see both) and the one that it does see appears as "Offline".
  • Device Manager sees both drives as operating correctly. They both have the correct drivers (HP-based driver for DPM and Symantec-based driver for BackupExec) and up-to-date firmware.

I tried disabling all of the BackupExec services and DPM still wasn't operating correctly. What can I try next?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

This issue has been resolved. Here's a quick rundown for anyone else who is having trouble with DPM and BackupExec on the same server.

The issue seemed to be that DPM didn't know how to handle the tape drive with the Symantec driver. When we would do a re-scan, the drives wouldn't show up correctly because it was choking on the Symantec driver. We fixed the issue with the following steps.

  • Remove the tape drive from any Protection plans in DPM (just the long-term aspect).
  • Unhook the SCSI tape drives from our server.
  • Reboot.
  • Do a library re-scan in DPM, make sure nothing shows up.
  • Hook up the SCSI tape drives again and reboot.
  • Install the HP drivers for BOTH tape drivers.
  • Reboot.
  • Do a library re-scan in DPM so it recognizes both drives.
  • Install Symantec tape driver for the drive used by BackupExec.
  • Reboot.
  • Add the tape drive back to the the Protection plans in DPM.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.