Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've set up dnsmasq on a virtal machine server in order to handle static wildcard subdomains on my local home network for development purposes.

The idea is to have * resolve to the VM itself (bridged networking), running the http and dns server.

I've installed dnsmasq on the VM. And edited dnsmasq.conf to resolve to the VM's network IP:

# Add domains which you want to force to an IP address here.
# The example below send any host in to a local
# webserver.

After adding the VM's ip to resolv.conf, pinging properly resolved to the machine's IP. When I try to ping it from the host machine, however, it acts like the there's no local dns and happily skips to the resolving it via internet, returning the webhost IP address. I tried listing it as the name server on both the host OS and the network router. No dice.

I'm very new to this, so I know I am probably doing something remarkably dumb. Could anyone offer a guess?

share|improve this question
up vote 0 down vote accepted

Found the problem -- port 53 was closed on my prepackaged LAMP stack.

ufw allow 53

Problem solved. Apologies.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.