Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have two RHEL5 boxes on a private network together (192.168.2.0/24) and I am trying to export a file system from one to the other but I keep getting the following error:

mount.nfs: Input/output error

on the client side I see this output:

mount: trying 192.168.2.101 prog 100003 vers 3 prot tcp port 2049
mount: trying 192.168.2.101 prog 100005 vers 3 prot tcp port 960

and on the server side I see this:

Sep 20 14:14:32 omicron mountd[18739]: authenticated mount request from 192.168.2.87:635 for /srv/nfs/web (/srv/nfs/web)

but that's all. I opened up iptables so that the whole 192.168.2.0/24 network is allowed to communicate freely but the public side is locked down to 22,80 etc....

any ideas?

share|improve this question
add comment

4 Answers

I had a similar problem, please have a look at this link.
And this one.

Basically you have to open much more ports.

share|improve this answer
add comment

Make sure portmapper is running

On centos

chkconfig --list | grep portmap

To start it on centos and set it to start at boot

service portmap start
chkconfig portmap on
share|improve this answer
add comment

Check the following:

  • On the server, can you read/write to and from /srv/nfs/web?
  • What's in your /etc/exports?
  • What's in /etc/hosts.*
  • What's in your /etc/sysconfig/iptables?
  • What happens if you service iptables stop on both hosts and then try to mount it?
  • The directory where you're trying to mount it you have read/write access to?
  • What mount options are you using/what is the line in /etc/fstab for the mount?
  • What is the output from 'showmount -a' and 'showmount -e'?
share|improve this answer
    
That should be in the comments, not in the answers. –  Rilindo Nov 30 '11 at 4:13
add comment

For a similar problem, I have added to the syntax of the mount command the following options "-o nolock, udp."

mount -o nolock,udp 192.168.4.11:/var/nfs /mnt/nfs/

Apparently this problem when the service nfslook is not 'started' successfully.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.