Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have two HP Procurve Wireless Access Point 420, model number J8130B. One of them works great, and the other isn't able to have its wireless configured. I have tried a factory reset of configuration.

It was handed to me by a coworker who said that over the console port on boot, he can see that the wireless card isn't found. When I go into the web interface, I can't configure an SSID because most of the drop downs are blank. The dropdown for setting the wireless channel is also blank.

In the top left corner of the web interface, it says it is a J8130A. The sticker on the AP definitely says J8130B. The working access point I have also says J8130B in its web interface.

I tried a firmware upgrade, and downgrade, even using the exact same firmware that I flashed the working access point with, and still no luck. I have reasoned that there must be something outside of the firmware that has been flashed in the past the wrong version of something, causing it not to work now. (The person that was working on it before flashed the bootloader as well.)

Any thoughts on how I can get the access point to think it is a J8130B again, and maybe recognize its wireless card?

Edit: I have found out that it does recognize the correct model on firmware 2.2.5. The version that is incorrectly recognized (on the trouble AP) is 2.1.7. We need the older firmware due to a bug in 2.2.5 causing other troubles on our network.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

That sounds like a "make it their problem" issue. Call in for the Warranty.

As an aside, when dealing with HP (especially with their enterprise hardware), I submit a ticket online, providing as much detail as possible. About 10 minutes after I receive the email confirmation of the ticket, I then call in to "inquire on the status." I find that I spend a lot less time with the Tier-1 "are you sure it's on / have you rebooted / are you sure the firmware is the latest version" techs.

UPDATE: Given the update about the firmware revisions, this is the kind of thing that they need to know. Submit as a ticket and let them turn it into a bug if they need to. I would ask that they notify you of any updated firmware for that hardware, though. (They do have a notification service that you can tie to your ITRC account, where you specify the hardware that you care about.)

share|improve this answer

I don't think this is a simple matter of flashing ad bad bootloader or firmware... It sounds more like it's a hardware problem. It's even quite possible you got a knock-off product. Lucally, HP has a lifetime warranty on that device... you could contact them & get a replacement if it's indeed REAL HP equipment. It's even possible that the wireless card inside has become dislodged... or the socket it is in has broken. Without voiding the warranty or contacting HP directly... I couldn't give you more info.

share|improve this answer
    
Yeah, I think I'll call HP. I know (as well as I can) that it isn't a knock off, because we buy refurbished direct from HP. The card inside works, as I just found out this AP works just fine on firmware 2.2.5. (I just edited my post to reflect this finding.) –  Brad Sep 20 '10 at 17:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.