Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I cannot get LDAP + SAMBA working ... I changed all the important files, but it seems that Samba does not even contact LDAP server. Whenever I would like to use smbclient, it writes:

check_ntlm_password:  Authentication for user [gigi] -> [gigi] FAILED with error NT_STATUS_NO_SUCH_USER

important changes pam.d

account required        pam_unix.so
account sufficient      pan_ldap.so

auth    required        pam_unix.so nullok_secure
auth    sufficient      pam_ldap.so use_first_pass

session required        pam_unix.so
session optional        pam_ldap.so

important changes nsswitch.conf

passwd:         compat ldap
group:          compat ldap
shadow:         compat ldap

test directory, smb.conf:

[skuska]
        public = no
        path = /sbin
        writable = no
        read only = yes
        guest ok = no
        browseable = yes
        valid users = gigi

I'm using tcpdump on ldap server, no connection is made by samba. Please help.

Thank you, Martin

share|improve this question
    
I dunno why but it is contacting LDAP server now. –  John Sep 21 '10 at 11:33
add comment

1 Answer 1

up vote 0 down vote accepted

Had you rebooted or restarted Samba or LDAP after the config changes? If not, the daemons wouldn't have read the changes to the config files yet, so were still running under the old config.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.