Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed ReviewBoard before on windows successfully. I am now trying to install it on Ubuntu.

Steps so far:

  1. Successfully installed ReviewBoard (can login into the web app)

  2. Connected Ubuntu to the windows Domain.

  3. I can successfully login as the user I wish to run ReviewBoard under.

  4. Tried to change /var/www/review/apache-mod-python.conf to have the something like the following (NOTE: These aren't actually my details)

    AuthLDAPBindDN "cn=LookUp,ou=People,dc=masd,dc=edu" AuthLDAPBindPassword masdsearch AuthLDAPAuthoritative off AuthLDAPCompareDNOnServer On AuthLDAPURL ldap://,dc=masd,dc=edu?sAMAccountName

However doing all this when i try and post to review board from my local machine I get the following error

Error uploading diff: One or more fields had errors (105)

{u'fields': {u'path': [u'HTTPS certificate not accepted. Please ensure that the proper certificate exists in /var/www/.subversion/auth for the user that reviewboard is running as.']}, u'stat': u'fail', u'err': {u'msg': u'One or more fields had errors', u'code': 105}}

Does anyone have ideas??

share|improve this question
up vote 1 down vote accepted

I fixed this using the following method

SVN checkout a file under the user Reviewboard is running under this will create a .Subversion/Auth/ directory in that users HOME.

I then simply recreated the .Suberversion/Auth/ directory in /var/www/ and everyhting worked as expected

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.