Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I´m trying to upgrade trac! from 0.10.3 to 0.12. Need help, i basiclally did steps shown here

http://trac.edgewall.org/wiki/TracUpgrade

got Linux version 2.6.18-6-686 (Debian 2.6.18.dfsg.1-18etch1) (waldi@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 SMP Sun Feb 10 22:11:31 UTC 2008

got Python 2.4.4 (#2, Jan 24 2010, 11:19:18)
mysql: Server version: 5.0.32-Debian_7etch11-log Debian etch distribution

So i went through this commands without errors:

todasana:~# easy_install —upgrade Trac0.12 Searching for Trac0.12


todasana:~# trac-admin /usr/local/apache2/htdocs/trac_catw3 upgrade


todasana:~# trac-admin /usr/local/apache2/htdocs/trac_catw3 wiki upgrade


todasana:~# trac-admin /usr/local/apache2/htdocs/trac_catw3 repository resync ‘*’


Didn´t do Step 5 Refresh static resources, because i did not understand it, and i think it does not apply to me: trac-admin /path/to/env deploy /deploy/path

then i restarted apache: /etc/init.d/apache2 restart

got this error in the browser now:
Mod_python error: "PythonHandler trac.web.modpython_frontend"
Traceback (most recent call last):
File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 299, in HandlerDispatch
result = object(req)
File "/var/lib/python-support/python2.4/trac/web/modpython_frontend.py", line 87, in handler
gateway.run(dispatch_request)
File "/var/lib/python-support/python2.4/trac/web/wsgi.py", line 87, in run
response = application(self.environ, self._start_response)
File "/var/lib/python-support/python2.4/trac/web/main.py", line 377, in dispatch_request
env = _open_environment(env_path, run_once=run_once)
File "/var/lib/python-support/python2.4/trac/web/main.py", line 58, in _open_environment
env_cache[env_path] = open_environment(env_path)
File "/var/lib/python-support/python2.4/trac/env.py", line 435, in open_environment
if env.needs_upgrade():
File "/var/lib/python-support/python2.4/trac/env.py", line 315, in needs_upgrade
if participant.environment_needs_upgrade(db):
File "/var/lib/python-support/python2.4/trac/env.py", line 373, in environment_needs_upgrade
raise TracError, 'Database newer than Trac version'

TracError: Database newer than Trac version

Yesterday i fixed the error, how ever got a new one! And the way i fixed the previous one i did not like, i think it was not really fixed and i'm getting more errors because of it

I changed a value on the database: UPDATE system SET value = ‘19’. (orginal value was 26)

Source control, and navigation work fine, however can´t create new ticket! i get:


Oops… Trac detected an internal error:

If you think this really should work and you can reproduce it, you should consider reporting this problem to the Trac team.

Go to trac.edgewall.org and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the Python traceback found below.

TracGuide — The Trac User and Administration Guide Python Traceback

Traceback (most recent call last): File "/var/lib/python-support/python2.4/trac/web/main.py", line 387, in dispatch_request dispatcher.dispatch(req) File "/var/lib/python-support/python2.4/trac/web/main.py", line 237, in dispatch resp = chosen_handler.process_request(req) File "/var/lib/python-support/python2.4/trac/ticket/web_ui.py", line 302, in process_request get_reporter_id(req, 'author')) File "/var/lib/python-support/python2.4/trac/ticket/web_ui.py", line 658, in _insert_ticket_data actions = TicketSystem(self.env).get_available_actions(ticket, req.perm) File "/var/lib/python-support/python2.4/trac/ticket/api.py", line 83, in get_available_actions return [action for action in actions.get(ticket['status'], ['leave']) File "/var/lib/python-support/python2.4/trac/ticket/model.py", line 104, in getitem return self.values[name] KeyError: 'status'

"

HOW EVER, if i change the database system value to 20, i THE SITE WORKS, however when i create a ticket i get the original error:


Mod_python error: "PythonHandler trac.web.modpython_frontend"

Traceback (most recent call last):

File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 299, in HandlerDispatch result = object(req)

File "/var/lib/python-support/python2.4/trac/web/ modpython_frontend.py", line 87, in handler gateway.run(dispatch_request)

File "/var/lib/python-support/python2.4/trac/web/wsgi.py", line 87, in run response = application(self.environ, self._start_response)

File "/var/lib/python-support/python2.4/trac/web/main.py", line 377, in dispatch_request env = _open_environment(env_path, run_once=run_once)

File "/var/lib/python-support/python2.4/trac/web/main.py", line 58, in _open_environment env_cache[env_path] = open_environment(env_path)

File "/var/lib/python-support/python2.4/trac/env.py", line 435, in open_environment if env.needs_upgrade():

File "/var/lib/python-support/python2.4/trac/env.py", line 315, in needs_upgrade if participant.environment_needs_upgrade(db):

File "/var/lib/python-support/python2.4/trac/env.py", line 373, in environment_needs_upgrade raise TracError, 'Database newer than Trac version'

TracError: Database newer than Trac version


any ideas ? Thank you!

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I suggest you to deploy a new environment of trac, move database (updated value of system to 19 as required) and config file, add another vhost for this instance and test again.

share|improve this answer
    
did all that before getting to this point, actually i created a new environment, i´m using the new database that is created when creating the environment, deleted the old vhost and added a new one, only change in config file was the addition to the svn path. –  Ernest Sep 21 '10 at 20:15
    
I would check dependencies: trac.edgewall.org/wiki/TracInstall#Dependencies, Trac changed dependecies radically from version to version. Check sqlite dependecy. If you are ok with the dependencies, backup trac (egg file) and reinstall using "easy_install Trac" –  Paul Sep 22 '10 at 4:12
    
So, I suggest a clean install for trac, test it empty and do changes in order to make it work, when it works migrate the db, config and reinstall plugins. –  Paul Sep 22 '10 at 11:29
    
i guess its the only way! fresh start. Thank you Paul –  Ernest Sep 22 '10 at 14:27
    
I suggested a fresh install for trac and a migration of db and plugins to the new trac install. –  Paul Sep 22 '10 at 14:48
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.