Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a task to disable CPU hotplug in RHEL5 kernel (2.6.18-el5.xxx). I have no problem recompiling an own kernel from the sources with an old config.

But as soon as I disable CPU hotplug, I get kernel panic during the boot, every boot with a different error codes.

So, is there any way to disable CPU hotplug on 2.6.18-el5? Or any other method to spread iowait between the CPUs in system? Our developers read somewhere that disabling CPU hotplug allows Linux kernel to do it. But how to turn a hotplug off?

It seems the CPU hotplug is not a feature but a requirement for the Linux kernel to work properly...

share|improve this question
    
btw. alexonlinux.com/… - here's described why hotplug=off does irq and iowait balancing –  disserman Sep 21 '10 at 19:19
    
have you tried to rebuild same kernel.src.rpm with rpmbuild? :) there are redhat patches included. –  GioMac Aug 10 '13 at 9:09
    
The kernel configuration item CONFIG_HOTPLUG_CPU support for suspend on SMP and hot-pluggable CPUs. It depends on: CONFIG_SMP && CONFIG_HOTPLUG && CONFIG_EXPERIMENTAL Try disabling all of them and check. CONFIG_HOTPLUG=n CONFIG_HOTPLUG_CPU=n CONFIG_SMP=n CONFIG_EXPERIMENTAL=n –  BKS Jan 12 at 20:01

2 Answers 2

Do you have irqbalance running? Are you working toward CPU affinity for interrupts or something closer to realtime operation? I think CPU hotplug has a dependency on the power management/ACPI features. Try disabling that support as well if you must eliminate the CPU hotplug.

share|improve this answer
    
Tried with both irqbalance running and a manual irq control. hdd controller/hba irq is stuck to one CPU. –  disserman Sep 22 '10 at 9:38
    
Tried to disable APM/ACPI, unfortunately 2.6.18 still can't boot with HOTPLUG_CPU=n –  disserman Sep 22 '10 at 9:39
    
And where do you want it to go? You can try a RedHat Realtime MRG kernel (or compile the sources) to get some additional functionality. I was able to bind an HP Smart Array controller to the CPU core of my choosing that way, but by default on RHEL 5, that same controller has interrupts distributed amongst all of the cores. –  ewwhite Sep 22 '10 at 15:37
1  
What are you trying to do? –  ewwhite Sep 22 '10 at 15:37

But as soon as I disable CPU hotplug, I get kernel panic during the boot, every boot with a different error codes.

It would be helpful to see what kind of panic you get. Is it the kernel-proper? Is it loading init? Is it mounting the root filesystem?

In short I suspect that your kernel build is bogus, not because you've disabled one option, but because you've not rebuilt the initrd, or updated grub, or similar. We can't really tell from so few details - but to answer your implied question "Yes, a kernel can boot without hotpluggable CPU support".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.