Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm adding a new router to the OSPF setup. Everything seems to be fine with the configuration but the state remains as INIT/DROTHER. When I do a ping to 224.0.0.5 from the new router all I get is:

CB# ping 224.0.0.5

Type escape sequence to abort. Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds: . CB#

Using ping to the same address at the other router is working fine.

Please advice.

ROUTER CB - 3825 advanced security 12.4(7c)

ROUTER IG - same router/IOS

ROUTER CB

version 12.4
!
hostname CB
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
ip cef
!
no ip dhcp use vrf connected
!
ip multicast-routing
!
interface Loopback1
 ip address 10.200.204.1 255.255.255.224
!
interface GigabitEthernet0/0
 description LAN Interface
 ip address 192.168.1.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip virtual-reassembly
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
 no mop enabled
!
interface GigabitEthernet0/0/0
 ip address 10.10.1.2 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip virtual-reassembly
 negotiation auto
!
router ospf 1
 log-adjacency-changes
 network 10.10.1.0 0.0.0.3 area 0
 network 192.168.1.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0 10.10.1.1 permanent

ROUTER IG

version 12.4
!
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
!
hostname IG
!
no aaa new-model
!
resource policy
!
no ip source-route
ip cef
ip tcp synwait-time 10
!
interface Loopback1
 ip address 10.200.200.1 255.255.255.0
!
interface GigabitEthernet0/0
 description LAN Interface
 bandwidth 1048576
 ip address 192.168.10.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 ip virtual-reassembly
 ip route-cache flow
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
 no mop enabled
!
interface GigabitEthernet0/1
 description to CCTV1
 ip address 172.10.1.1 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 ip pim dense-mode
 ip virtual-reassembly
 ip route-cache flow
 ip ospf cost 10
 ip ospf hello-interval 1
 ip ospf dead-interval 2
 ip ospf retransmit-interval 3
 ip ospf transmit-delay 3
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
 no mop enabled
!
interface GigabitEthernet0/1/0
 description Service Provider Fiber Link
 no ip address
 negotiation auto
!
interface GigabitEthernet0/1/0.10
 description to CCTV2
 encapsulation dot1Q 10
 ip address 172.10.2.1 255.255.255.252
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 ip ospf hello-interval 1
 ip ospf dead-interval 2
 ip ospf retransmit-interval 3
 ip ospf transmit-delay 3
 no snmp trap link-status
 no cdp enable
!
interface GigabitEthernet0/1/0.32
 description to CB
 encapsulation dot1Q 32
 ip address 10.10.1.1 255.255.255.252
 no snmp trap link-status
 no cdp enable
!
router ospf 1
 log-adjacency-changes
 network 10.10.1.0 0.0.0.3 area 0
 network 172.10.1.0 0.0.0.3 area 0
 network 172.10.2.0 0.0.0.3 area 0
 network 192.168.10.0 0.0.0.255 area 0
! 
ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX
share|improve this question
1  
Could you post your configurations related to PIM, etc? Its more likely its a multicast related issue rather than a routing issue if you have another router thats working? –  zv_ Sep 22 '10 at 14:21
1  
Type of router/OS? –  Chris S Sep 22 '10 at 15:02

2 Answers 2

First, I would ping other devices on the same netblock (in this case 10.10.1.1 and 10.10.1.2), to see if there's any response. If you have basic L3 connectivity, I'd then start looking at OSPF event debugging or OSPF packet debugging.

I wouldn't rely on any ping response from the OSPF multicast IPs, though.

Edit: Ah, You've explicitly configured a variety of OSPF intervals on one of the routers. These much match on all routers forming an adjacency, so when the Hello packets are sent, they're immediately dropped as invalid.

share|improve this answer
    
Vatine ping between devices is working fine and they both work when using static routes –  3D1L Sep 22 '10 at 18:19
    
@3D1L: You're setting OSPF timers on one side, but not on the other side, either let both be default or replicate the timer configuration on both sides. –  Vatine Sep 24 '10 at 11:12
    
Timers were removed but is not working either –  3D1L Sep 28 '10 at 15:05
up vote 0 down vote accepted

The router need to be power re-cycled after boot up everything started to work fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.