Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to install a goddaddy ssl certificate on my dedicated plesk web server machine for a rails app that is working fine with non-https using mongrel cluster and apache mod_proxy to redirect the requests to the rails app. I have installed many certs for regular php based websites countless times and the certificate is installed properly but I cannot seem to get mod_proxy to forward on the requests no matter what I've tried. I have tried all combinations of the following and the errors I get in the logs:

`
Order deny,allow
Allow from all

SSLProtocol all
SSLCertificateFile /etc/httpd/ssl/mydomain.com.crt
SSLCertificateKeyFile /etc/httpd/ssl/mydomain.com.key
SSLCertificateChainFile /etc/httpd/ssl/gd_intermediate_bundle.crt
SSLProxyEngine on
ProxyPass / https://www.mydomain.com:3003/
ProxyPreserveHost on
`

I keep getting errors in the logs similar to:
[error] (502)Unknown error 502: proxy: pass request body failed to 64.71.183.241:3003 (www.mydomain.com)
[error] proxy: pass request body failed to 64.71.183.241:3003 (www.mydomain.com) from 204.16.153.250 ()

and

[error] [client 64.71.183.241] SSL Proxy requested for mydomain.com:443 but not enabled [Hint: SSLProxyEngine]
[error] proxy: HTTPS: failed to enable ssl support for 64.71.183.241:3003 (www.mydomain.com)

Any help would be appreciated, google is not helping me figure this out and I've tried about every combination possible.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I have a similar configuration that works:

  # SSL
  SSLEngine On
  SSLCipherSuite HIGH:MEDIUM
  SSLCertificateFile    /etc/apache2/ssl/mydomain.com.crt
  SSLCertificateKeyFile /etc/apache2/ssl/mydomain.com.key

  ProxyPass / http://www.mydomain.com:3003/
  ProxyPassReverse / http://www.mydomain.com:3003/
  ProxyPreserveHost on

Hope it helps (although I can't explain every parameter). Perhaps you might want to use http instead of https for the ProxyPass, because it's just a redirect to localhost and mongrel doesn't support (?) or doesn't come with activated SSL support IMHO.

share|improve this answer
    
Thanks so much for the help sebs. Well the funny thing is changing the https to http was part of the answer. Also for some reason I had to remove the SSLCertificateFile/KeyFile references. When I included them it would go in an infinite loop of sorts and lock up the web server. Guess it didn't need to be told where the certs were after all. The only quirk is if I go to the website root securely it redirects to the non-secure version but any other url off the root it's keeping it secure so that works for now since we won't be securing the home page currently. But wonder why that is... –  zonathen Sep 24 '10 at 16:19
    
Woah now it doesnt seem to be redirecting to non secure on root. Good to go! Thanks again Sebs you rock! –  zonathen Sep 24 '10 at 16:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.