Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Lucid Ubuntu Server running in a EBS 2008 windows domain. This server is running Nagios and I would like it to send email notifications to the Exchange 2007 server. I have installed mailutils and run a dpkg-reconfigure exim4-config however I still don't have it setup correctly.

I have been trying to send an email via command line first as a proof of concept for the Nagios command but the exim4 log file says:

2010-09-23 11:29:32 Start queue run: pid=8248
2010-09-23 11:29:53 1OySgu-0002xV-5N internet.domain.com.au [**my external IP**] Connection timed out
2010-09-23 11:29:53 1OySgu-0002xV-5N == hsee@domain.com.au R=dnslookup T=remote_smtp defer (110): Connection timed out
2010-09-23 11:29:53 End queue run: pid=8248
2010-09-23 11:59:32 Start queue run: pid=9958
2010-09-23 11:59:32 1OySgu-0002xV-5N == hsee@domain.com.au R=dnslookup T=remote_smtp defer (-53): retry time not reached for any host

I can telnet into the exchange server via 25 with the exchange machine IP.

I would like it configured correctly for just a simple internal network direct send to my exchange server. From looking at the log it seems like it wants to go out onto the Internet first instead of staying internal.

Any suggestions?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

You need to configure your exim4 installation as a smarthost setup. This can be done by re-running dpkg-reconfigure and selecting the correct option. Then enter the name (or IP address) of your Exchange Server as the smarthost.

Make sure that the smarthost actually has an account (or a contact) set up for the email address you want to use. You may also have to do something about authentication (depends on your Exchange server configuration).

share|improve this answer
    
Yep spot on. After a bit more looking at docco and exim config files I needed to have a smarthost scenario setup. The dc_smarthost var now contains my SMTP. Thanks for posting! –  Qwerty Sep 24 '10 at 0:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.