Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm working on a Windows Server 2008 R2 (x64) VirtualBox image that I've set up as a CI/deployment testing environment. I've got VirtualBox set to use Internal-Only networking. I've set up hosts file redirects for the names of my production machines/database:

127.0.0.1      webserv1
127.0.0.1      webserv2
127.0.0.1      dbserv1
etc.

And my deployment script will then attempt to deploy to each address in turn.

My problem is that when I try to hit \\webserv1\d$\deployment-directory, or even \\webserv1\d$\, I'm getting an authorization prompt and I'm denied access. I'm running as administrator on the VirtualBox console; I can't get any more authorized. I can hit \\127.0.0.1\d$\deployment-directory.

I've even disabled the network adapter to make sure I wasn't somehow hitting the real production boxes (and I verified that I can still hit localhost with the machine in that condition).

Any tips?

share|improve this question
    
How are you running your script? Is it like a DOS batch file, PowerShell, something else? –  Coding Gorilla Sep 23 '10 at 20:29
    
You are using the Administrator account or an account that is an administrator? Only the former (or a full Domain Admin) works on W2K8\R2. –  Helvick Sep 23 '10 at 20:33
    
It's the Administrator account. The fix was registry-based - I'll post an answer. –  arootbeer Sep 23 '10 at 22:13

1 Answer 1

up vote 3 down vote accepted

This ended up being related to name resolution and permissions. The details are found in this post: http://forums.techarena.in/server-networking/1195474.htm

Basically there are several registry entries which must be created in order to enable this configuration - out of the box Windows does not support it.

share|improve this answer
    
It's OK to mark this Accepted. It lets people know that this problem has been solved. –  sysadmin1138 Sep 23 '10 at 22:20
    
+1. Good catch. This is a fairly common occurrence. It wasn't evident in your question that this was the problem you were running in to, but after reading your solution and re-reading your question the light bulb went on. ;) –  joeqwerty Sep 23 '10 at 22:22
    
I'll mark it accepted when it lets me - there's a 2-day waiting period for self-answers. –  arootbeer Sep 23 '10 at 22:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.