Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Based on

I've tried the command

sc sdset My.Service (A;;RPWP;;;S-1-1-0)

which i believe should give all users permission to restart My.Service

when I run the command

the error is:

[SC] ConvertStringSecurityDescriptorToSecurityDescriptor FAILED 87:    
wrong parameter

What am I doing wrong?


sc sdset My.Service D:(A;;RPWP;;;S-1-1-0)

sc succeeds, but net.exe and sc.exe gives permission denied

share|improve this question
up vote 2 down vote accepted

You need to prefix the entires with D: like this:

sc sdset My.Service D:(A;;RPWP;;;S-1-1-0)
share|improve this answer
SC says ok, but afterwards I get permission denied on net start My.Service and sc delete My.Service . I've now removed said service from regedit, but obviously I am taking the wrong approach. It seems sc clears all previous permissions – Esben Skov Pedersen Sep 24 '10 at 14:54
Solution: sc sdshow My.Service => merge result with (A;;RPWP;;;S-1-1-0) – Esben Skov Pedersen Sep 24 '10 at 15:03
+1 You beat me to it :) – Will Sep 24 '10 at 15:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.