Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When in a terminal window, right-clicking often opens a new terminal rather than displaying the menu. (I'm not sure if this is because of where I click, or if I'm hitting another button, or something else -- but it happens often, maybe 5 times a day.)

Is there a way to disable this behavior?

(I'm not sure what causes this, exactly... Metacity? GNOME? I don't think it's the shell itself.)

share|improve this question

2 Answers 2

up vote 3 down vote accepted

In gnome-terminal, if you right-click and hold, you'll see a context menu. The first item is Open Terminal. It is likely that you're moving the mouse a little and releasing the button thus selecting that option.

Edit:

You can edit the file at /usr/share/gnome-terminal/terminal.xml and rearrange the order of the items in the <popup name="Popup" action="Popup"> section. You could put Copy and Paste at the top swapping positions with Open Window and Open Tab.

share|improve this answer
    
That is almost surely it. Is there a way to modify the menu? –  Charles Sep 24 '10 at 19:39
    
@Charles: See my edit. –  Dennis Williamson Sep 24 '10 at 19:57
    
Fantastic! This does exactly what I want. –  Charles Sep 26 '10 at 4:07

Doesn't sound quite right for behavior. If you create a "blank" account (new user) and log in, does the same behavior persist? Sounds like a preference was changed.

share|improve this answer
    
Yes, same behavior. I'm not sure exactly what I'm doing that triggers it (it's always on a right-click, but by no means on all right-clicks). It'[s really annoying... –  Charles Sep 24 '10 at 18:52
    
Is there a setting that changed your right-click behavior preference for the mouse in the preferences/settings? –  Bart Silverstrim Sep 24 '10 at 19:17
    
I don't know of any such settings. The mouse is pretty standard, nothing fancy -- no custom drivers. –  Charles Sep 24 '10 at 19:30
    
You're running latest Ubuntu with standard interface? –  Bart Silverstrim Sep 24 '10 at 19:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.