Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Guys, really, I know this is a super newbie question, but I've done all of my homework. I've googled it and duckduckgo'd it, but to no avail.

How can I set AllowOverride All? Whenever I do this:

<Directory "/var/www/domain.com/public_html">
  AllowOverride All
</Directory>

It does not work! :\

share|improve this question
    
Technically, if you tried everything you'd have found a solution... –  Bart Silverstrim Sep 24 '10 at 18:40
2  
Technically, yes. In this case it was to emphasize out my efforts –  nicko Sep 24 '10 at 19:00

2 Answers 2

Have you changed the AccessFileName directive?

Are the permissions for your .htaccess files set such that Apache can read the files?

Are you restarting Apache between changes to the AllowOverride directive?

share|improve this answer
    
Yes to all. I found the problem was that my installation of the script that I was installing did transfer over its .htaccess files. –  nicko Sep 24 '10 at 20:06

Correct me if I'm wrong (I'm fairly new to this too), but don't you need:

Order allow,deny
Allow from all

Right below AllowOverride All?

<Directory "/var/www/domain.com/public_html">
  AllowOverride All
  Order allow,deny
  Allow from all
</Directory>
share|improve this answer
    
I just tried that now but it didn't make a difference :\ –  nicko Sep 24 '10 at 18:58
    
And yes, I do have mod_rewrite enabled. –  nicko Sep 24 '10 at 18:58
    
Order and Allow have almost nothing to do with AllowOverride. –  Chris S Sep 24 '10 at 19:47
    
Ah. This is good to know. Thanks, Chris! –  Aeo Sep 27 '10 at 14:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.