Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Since today the maven builds in hudson started failing with this stacktrace:

Parsing POMs
[workspace] $ /usr/lib/jvm/java-6-sun/bin/java -cp /usr/share/tomcat5.5/.hudson/plugins/maven-plugin/WEB-INF/lib/maven-agent-1.377.jar:/usr/share/maven2/boot/classworlds.jar hudson.maven.agent.Main /usr/share/maven2 /var/lib/tomcat5.5/webapps/hudson/WEB-INF/lib/remoting-1.377.jar /usr/share/tomcat5.5/.hudson/plugins/maven-plugin/WEB-INF/lib/maven-interceptor-1.377.jar 37299
<===[HUDSON REMOTING CAPACITY]===>���channel started
channel stopped
ERROR: Failed to parse POMs
java.io.IOException: Remote call on Channel to Maven [/usr/lib/jvm/java-6-sun/bin/java, -cp, /usr/share/tomcat5.5/.hudson/plugins/maven-plugin/WEB-INF/lib/maven-agent-1.377.jar:/usr/share/maven2/boot/classworlds.jar, hudson.maven.agent.Main, /usr/share/maven2, /var/lib/tomcat5.5/webapps/hudson/WEB-INF/lib/remoting-1.377.jar, /usr/share/tomcat5.5/.hudson/plugins/maven-plugin/WEB-INF/lib/maven-interceptor-1.377.jar, 37299] failed
 at hudson.remoting.Channel.call(Channel.java:566)
 at hudson.maven.ProcessCache$MavenProcess.call(ProcessCache.java:156)
 at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:468)
 at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:416)
 at hudson.model.Run.run(Run.java:1273)
 at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:291)
 at hudson.model.ResourceController.execute(ResourceController.java:88)
 at hudson.model.Executor.run(Executor.java:137)
Caused by: java.lang.NoClassDefFoundError: hudson/maven/agent/PluginManagerInterceptor
 at hudson.maven.MavenBuilder.call(MavenBuilder.java:218)
 at hudson.maven.MavenModuleSetBuild$Builder.call(MavenModuleSetBuild.java:681)
 at hudson.maven.MavenModuleSetBuild$Builder.call(MavenModuleSetBuild.java:625)
 at hudson.remoting.UserRequest.perform(UserRequest.java:114)
 at hudson.remoting.UserRequest.perform(UserRequest.java:48)
 at hudson.remoting.Request$2.run(Request.java:270)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
 at java.util.concurrent.FutureTask.run(FutureTask.java:138)
 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
 at java.lang.Thread.run(Thread.java:619)

Any ideas?

share|improve this question
add comment

2 Answers

I have seen this a few times on my Hudson build slaves. I'm not sure what the root cause is, but deleting the workspace and letting Hudson rebuild it and in particular re-download java seemed to work.

Of course, if this is happening on the master node, that won't help you much.

share|improve this answer
add comment

Is your maven plugin version in sync with your hudson version? I would also check if you can build the projects from command line. As dsolimano said he wipes out the workspace. Not sure how redownloading java fits into the picture.

I haven't experienced this, since I never use update with my SCM. I experienced issues when using update with subversion. We were not able to track down the root cause (may be out of sync clocks), but the fix for us was always deleting the whole source folder and download the entire project. So we always run a clean build from scratch.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.