Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an existing Apache 2.2.3 server running on Red Hat Enterprise in production. Unfortunately, I now have a need to use https, and mod_ssl is not installed. I was hoping I could do this in yum and avoid recompiling Apache. But when I do:

yum install mod_ssl

I get a dependency error:

Missing Dependency: httpd = 2.2.3-22.el5_3.1 is needed by package 1:mod_ssl-2.2.3-22.el5_3.1.i386 (rhel-i386-server-5)

I guess I'm not sure how to get Apache recognized with that version number. "yum upgrade httpd" finds nothing to upgrade. "yum clean all" doesn't help. Anyone have any ideas?

If I am stuck with recompiling httpd, what's the best way to make sure I don't hose the server in the process?

share|improve this question
add comment

3 Answers

Well, I couldn't figure it out. We went ahead and recompiled Apache with mod_ssl enabled and all is well now.

share|improve this answer
add comment

Unless RedHat has done something really funny, mod_ssl was only separate with Apache 1.3.x. You should already have it installed with Apache 2.x. You probably just need to enable the module. (The modssl website clearly says Apache 1.3)

If that's not the case, it appears you need to install the patches for RHSA-2009:1075-01. That version its asking for is from said update.

share|improve this answer
    
Thanks - mod_ssl is included with Apache 2, but isn't on this box for some reason. Apparently I can recompile with --enable-ssl, I just hate to do that on prod. I do have that Red Hat update installed. So here's the maddening part: yum install httpd-2.2.3-22.el5_3.1 Package matching httpd-2.2.3-22.el5_3.1.i386 already installed. Checking for update. Nothing to do But then: yum install mod_ssl-2.2.3-22.el5_3.1 Error: Missing Dependency: httpd = 2.2.3-22.el5_3.1 is needed by package 1:mod_ssl-2.2.3-22.el5_3.1.i386 (rhel-i386-server-5) Yum seems to be confused. –  rich Jun 3 '09 at 21:27
    
@rich: wow, that looks messed up. I'd try using RPM directly... but I'd be hesitant of proceeding on a production box. Word of warning, I'm a Debian guy, so the answer may be immediately obvious to a RedHat expert. –  derobert Jun 5 '09 at 5:01
add comment

You might just need to install the openssl package. Try looking into that.

share|improve this answer
    
hi skitzot, thanks, I did confirm that openssl is installed: # openssl version OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008 –  rich Jun 3 '09 at 16:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.